CVE-2026-87908
CVE-2026-87908 · multiparty vulnerable to Denial of Service via unbounded part-header accumulation
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
multiparty is a Node.js library for parsing multipart/form-data request bodies. In versions from 2.1.0 up to but not including 4.3.1, the parser does not bound the amount of memory used while accumulating the headers of a single multipart part. An unauthenticated attacker can send a single request whose part carries a very large volume of header bytes, forcing the parser to buffer all of them and exhausting the process memory, which crashes the server. This is a denial of service with no confidentiality or integrity impact. The issue is fixed in multiparty 4.3.1, which caps the size of the accumulated part headers. Users should upgrade to multiparty 4.3.1 or later.
CVSS 7.5 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
multiparty
- Версии
- ≥ 2.1.0, < 4.3.1: Затронуто (semver)
- 4.3.1: Не затронуто (semver)
Обновитесь до 4.3.1
node-multiparty Debian:12
- Версии
- 4.2.3-2
- 4.2.3-3
- 4.2.3-4
- 4.2.3-5
- 4.3.0+~4.2.1-1
- 4.3.0-1
- 4.3.1+~4.2.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Debian:13
- Версии
- 4.2.3-3
- 4.2.3-4
- 4.2.3-5
- 4.3.0+~4.2.1-1
- 4.3.0-1
- 4.3.1+~4.2.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Debian:14
- Версии
- 4.2.3-3
- 4.2.3-4
- 4.2.3-5
- 4.3.0+~4.2.1-1
- 4.3.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.3.1+~4.2.1-1
Обновитесь до 4.3.1+~4.2.1-1
node-multiparty Ubuntu:16.04:LTS
- Версии
- 4.0.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Ubuntu:18.04:LTS
- Версии
- 4.0.0-1
- 4.0.0-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Ubuntu:20.04:LTS
- Версии
- 4.2.1-1
- 4.2.1-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Ubuntu:22.04:LTS
- Версии
- 4.2.2-2
- 4.2.2-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Ubuntu:24.04:LTS
- Версии
- 4.2.3-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Ubuntu:26.10
- Версии
- 4.2.3-5
- 4.3.0+~4.2.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
node-multiparty Ubuntu:26.04:LTS
- Версии
- 4.2.3-3
- 4.2.3-4build1
- 4.2.3-5
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления