CVE-2026-93337
CVE-2026-93337 · NetworkManager-l2tp Privilege Escalation via pppd Plugin Injection
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains an improper input validation vulnerability that allows local users with VPN connection creation permissions to inject arbitrary pppd directives by supplying mru or mtu property values containing trailing non-numeric content after a valid integer. Attackers can exploit the verbatim write of unvalidated strings into the pppd options file via write_config_option() to inject the plugin directive, causing the privileged pppd process to load an attacker-controlled shared object and achieve arbitrary code execution as root.
CVSS 8.5 · Высокий · EPSS 0,1% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
networkmanager-l2tp
- Версии
- ≥ 0, ≤ 1.52.4: Затронуто (semver)
- 1.52.6: Не затронуто (semver)
Обновитесь до 1.52.6
network-manager-l2tp Debian:12
- Версии
- 1.20.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.20.8-1+deb12u1
Обновитесь до 1.20.8-1+deb12u1
network-manager-l2tp Debian:13
- Версии
- 1.20.20-2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.20.20-2+deb13u1
Обновитесь до 1.20.20-2+deb13u1
network-manager-l2tp Debian:14
- Версии
- 1.20.20-2
- 1.52.0-1
- 1.52.0-2
- 1.52.2-1
- 1.52.4-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.52.6-1
Обновитесь до 1.52.6-1
network-manager-l2tp Ubuntu:18.04:LTS
- Версии
- 1.2.8-1
- 1.2.8-2build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
network-manager-l2tp Ubuntu:20.04:LTS
- Версии
- 1.2.10-1
- 1.2.14-1
- 1.2.16-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
network-manager-l2tp Ubuntu:22.04:LTS
- Версии
- 1.2.18-1build1
- 1.20.0-1
- 1.20.0-1build1
- 1.20.0-1build2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
network-manager-l2tp Ubuntu:24.04:LTS
- Версии
- 1.20.8-1
- 1.20.10-1
- 1.20.12-1
- 1.20.12-1build1
- 1.20.12-1build2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
network-manager-l2tp Ubuntu:26.04:LTS
- Версии
- 1.20.20-2
- 1.52.0-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/nm-l2tp/NetworkManager-l2tp/security/advisories/GHSA-rp84-8h2r-5xc3
- https://github.com/nm-l2tp/NetworkManager-l2tp/commit/64879ce0ad866f7c9a45babe4d95731a916ea00f
- https://www.vulncheck.com/advisories/networkmanager-l2tp-privilege-escalation-via-pppd-plugin-injection
- https://nvd.nist.gov/vuln/detail/CVE-2026-93337