p PatchFirst

CVE-2026-9358

CVE-2026-9358 · postcss-selector-parser AST Serialization container.js toString recursion

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was determined in postcss-selector-parser up to 6.1.2/7.1.2. Affected is the function toString of the file src/selectors/container.js of the component AST Serialization. Executing a manipulation can lead to uncontrolled recursion. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 6.1.3 and 7.1.3 is able to address this issue. This patch is called 5bc698cef66f8abd12610dc623e5d67cbc0f869d. It is suggested to upgrade the affected component. The vendor explains, that according to his definition "DoS on server-side on user-generated CSS is low risk for us (since most users compile own CSS with PostCSS)." The commits were backported to 6.x branch, which was the most downloaded version.

CVSS 5.3 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • postcss-selector-parser

    Версии
    • 6.1.0: Затронуто
    • 6.1.1: Затронуто
    • 6.1.2: Затронуто
    • 7.1.0: Затронуто
    • 7.1.1: Затронуто
    • 7.1.2: Затронуто
    • 6.1.3: Не затронуто
    • 7.1.3: Не затронуто

    Обновитесь до 6.1.3; Обновитесь до 7.1.3

  • node-css-loader Debian:12

    Версии
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    • 6.11.0+~cs15.5.7-3
    • 6.7.2+~cs14.0.11-1
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Debian:13

    Версии
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    • 6.11.0+~cs15.5.7-3
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Debian:14

    Версии
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.8.1+~cs14.1.4-1

    Обновитесь до 6.8.1+~cs14.1.4-1

  • postcss-selector-parser npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 6.1.0, < 6.1.3

    Обновитесь до 6.1.3

  • postcss-selector-parser npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.1.0, < 7.1.3

    Обновитесь до 7.1.3

  • node-css-loader Ubuntu:20.04:LTS

    Версии
    • 1.0.1-1
    • 1.0.1+repack-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Ubuntu:22.04:LTS

    Версии
    • 5.0.1+~cs14.0.5-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Ubuntu:24.04:LTS

    Версии
    • 6.7.2+~cs14.0.11-1
    • 6.8.1+~cs14.0.17-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Ubuntu:25.10

    Версии
    • 6.8.1+~cs14.0.17-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Ubuntu:26.10

    Версии
    • 6.8.1+~cs14.0.17-2
    • 6.8.1+~cs14.1.4-1
    • 6.11.0+~cs15.5.7-1
    • 6.11.0+~cs15.5.7-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-css-loader Ubuntu:26.04:LTS

    Версии
    • 6.8.1+~cs14.0.17-1
    • 6.8.1+~cs14.0.17-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →