p PatchFirst

CVE-2026-9595

CVE-2026-9595 · webpack-dev-server vulnerable to HMR WebSocket interception via permissive user proxies

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Impact: When a user-configured proxy on webpack-dev-server has a broad context (e.g. /) and ws: true, it also intercepts the dev server's own HMR WebSocket and forwards it to the proxy target. This leaks the browser's cookies and Origin header to the backend, bypasses the dev server's Host/Origin validation, and corrupts the HMR socket (both HMR and the proxy end up writing to the same socket). Patches: Fixed in webpack-dev-server@5.2.5. Workarounds: Scope user-defined proxy context to specific paths instead of /, or omit ws: true from the proxy entry when WebSocket forwarding is not required.

CVSS 5.3 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • webpack-dev-server

    Версии
    • ≥ 0, < 5.2.5: Затронуто (semver)
    • 5.2.5: Не затронуто (semver)

    Обновитесь до 5.2.5

  • webpack-dev-server npm

    Затронутые диапазоны версий
    • SEMVER: < 5.2.5

    Обновитесь до 5.2.5

  • node-webpack Ubuntu:18.04:LTS

    Версии
    • 3.5.6-1build3
    • 3.5.6-1build4
    • 3.5.6-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-webpack Ubuntu:20.04:LTS

    Версии
    • 4.7.0-3
    • 4.30.0-7
    • 4.30.0-9
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • vue.js Ubuntu:20.04:LTS

    Версии
    • 2.5.17+dfsg-4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-webpack Ubuntu:22.04:LTS

    Версии
    • 4.43.0-6build4
    • 4.43.0-7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • vue.js Ubuntu:22.04:LTS

    Версии
    • 2.6.12+dfsg-3
    • 2.6.14+dfsg-1
    • 2.6.14+dfsg-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-webpack Ubuntu:24.04:LTS

    Версии
    • 5.76.1+dfsg1+~cs17.16.16-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • vue.js Ubuntu:24.04:LTS

    Версии
    • 2.6.14+dfsg1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-webpack Ubuntu:25.10

    Версии
    • 5.97.1+dfsg1+~cs11.18.27-2
    • 5.97.1+dfsg1+~cs11.18.27-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • vue.js Ubuntu:25.10

    Версии
    • 2.6.14+dfsg1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-webpack Ubuntu:26.10

    Версии
    • 5.105.4+dfsg1+~cs15.13.23-2
    • 5.108.0+dfsg1+~cs14.7.20-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • vue.js Ubuntu:26.10

    Версии
    • 2.6.14+dfsg1-3
    • 2.7.16+dfsg1-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-webpack Ubuntu:26.04:LTS

    Версии
    • 5.97.1+dfsg1+~cs11.18.27-3
    • 5.97.1+dfsg1+~cs11.18.27-4
    • 5.105.4+dfsg1+~cs15.13.23-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • vue.js Ubuntu:26.04:LTS

    Версии
    • 2.6.14+dfsg1-1
    • 2.6.14+dfsg1-1build1
    • 2.6.14+dfsg1-2
    • 2.6.14+dfsg1-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →