p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости mariadb-10.5 · Страница 3

За последние 30 дней в mariadb-10.5 опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 73

  1. CVE-2022-27379

    Высокий · CVSS 7.5EPSS 2,26%Есть исправление

    CVE-2022-27379

    An issue in the component Arg_comparator::compare_real_fixed of MariaDB Server v10.6.2 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.

    • Обновитесь до 1:10.5.18-0+deb11u1
    Опубликовано Обновлено
  2. CVE-2022-27378

    Высокий · CVSS 7.5EPSS 2,41%Есть исправление

    CVE-2022-27378

    An issue in the component Create_tmp_table::finalize of MariaDB Server v10.7 and below was discovered to allow attackers to cause a Denial of Service (DoS) via specially crafted SQL statements.

    • Обновитесь до 1:10.5.18-0+deb11u1
    Опубликовано Обновлено
  3. CVE-2022-27377

    Высокий · CVSS 7.5EPSS 2,34%Есть исправление

    CVE-2022-27377

    MariaDB Server v10.6.3 and below was discovered to contain an use-after-free in the component Item_func_in::cleanup(), which is exploited via specially crafted SQL statements.

    • Обновитесь до 1:10.5.18-0+deb11u1
    Опубликовано Обновлено
  4. CVE-2022-27376

    Высокий · CVSS 7.5EPSS 2,2%Есть исправление

    CVE-2022-27376

    MariaDB Server v10.6.5 and below was discovered to contain an use-after-free in the component Item_args::walk_arg, which is exploited via specially crafted SQL statements.

    • Обновитесь до 1:10.5.18-0+deb11u1
    Опубликовано Обновлено
  5. CVE-2022-24052

    Высокий · CVSS 7EPSS 0,69%Есть исправление

    CVE-2022-24052

    MariaDB CONNECT Storage Engine Heap-based Buffer Overflow Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16190.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  6. CVE-2022-24051

    Высокий · CVSS 7EPSS 0,66%Есть исправление

    CVE-2022-24051

    MariaDB CONNECT Storage Engine Format String Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of proper validation of a user-supplied string before using it as a format specifier. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16193.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  7. CVE-2022-24050

    Высокий · CVSS 7EPSS 0,64%Есть исправление

    CVE-2022-24050

    MariaDB CONNECT Storage Engine Use-After-Free Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16207.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  8. CVE-2022-24048

    Высокий · CVSS 7EPSS 0,69%Есть исправление

    CVE-2022-24048

    MariaDB CONNECT Storage Engine Stack-based Buffer Overflow Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of MariaDB. Authentication is required to exploit this vulnerability. The specific flaw exists within the processing of SQL queries. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service account. Was ZDI-CAN-16191.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  9. CVE-2021-46661

    Средний · CVSS 5.5EPSS 0,4%Есть исправление

    CVE-2021-46661

    MariaDB through 10.5.9 allows an application crash in find_field_in_tables and find_order_in_list via an unused common table expression (CTE).

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  10. CVE-2021-46662

    Средний · CVSS 5.5EPSS 0,39%Есть исправление

    CVE-2021-46662

    MariaDB through 10.5.9 allows a set_var.cc application crash via certain uses of an UPDATE statement in conjunction with a nested subquery.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  11. CVE-2021-46664

    Средний · CVSS 5.5EPSS 0,4%Есть исправление

    CVE-2021-46664

    MariaDB through 10.5.9 allows an application crash in sub_select_postjoin_aggr for a NULL value of aggr.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  12. CVE-2021-46665

    Средний · CVSS 5.5EPSS 0,4%Есть исправление

    CVE-2021-46665

    MariaDB through 10.5.9 allows a sql_parse.cc application crash because of incorrect used_tables expectations.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  13. CVE-2021-46666

    Средний · CVSS 5.5EPSS 0,39%Есть исправление

    CVE-2021-46666

    MariaDB before 10.6.2 allows an application crash because of mishandling of a pushdown from a HAVING clause to a WHERE clause.

    • Обновитесь до 1:10.5.11-1
    Опубликовано Обновлено
  14. CVE-2021-46668

    Средний · CVSS 5.5EPSS 0,4%Есть исправление

    CVE-2021-46668

    MariaDB through 10.5.9 allows an application crash via certain long SELECT DISTINCT statements that improperly interact with storage-engine resource limitations for temporary data structures.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено
  15. CVE-2021-46669

    Высокий · CVSS 7.5EPSS 2,42%Есть исправление

    CVE-2021-46669

    MariaDB through 10.5.9 allows attackers to trigger a convert_const_to_int use-after-free when the BIGINT data type is used.

    • Обновитесь до 1:10.5.18-0+deb11u1
    Опубликовано Обновлено
  16. CVE-2021-46658

    Средний · CVSS 5.5EPSS 0,39%Есть исправление

    CVE-2021-46658

    save_window_function_values in MariaDB before 10.6.3 allows an application crash because of incorrect handling of with_window_func=true for a subquery.

    • Обновитесь до 1:10.5.11-1
    Опубликовано Обновлено
  17. CVE-2021-46659

    Средний · CVSS 5.5EPSS 0,56%Есть исправление

    CVE-2021-46659

    MariaDB before 10.7.2 allows an application crash because it does not recognize that SELECT_LEX::nest_level is local to each VIEW.

    • Обновитесь до 1:10.5.15-0+deb11u1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →