p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости thrift · Страница 5

За последние 30 дней в thrift опубликовано уязвимостей: 61; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 91

  1. CVE-2026-41607

    Средний · CVSS 6.5EPSS 0,9%Нет опубликованного исправления

    Apache Thrift: C++ JSON OOB read

    Out-of-bounds Read vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Опубликовано Обновлено
  2. CVE-2026-41606

    Средний · CVSS 5.3EPSS 1,1%Нет опубликованного исправления

    Apache Thrift: c_glib dispatch stack overflow

    Uncontrolled Recursion vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Опубликовано Обновлено
  3. CVE-2026-41605

    Высокий · CVSS 7.3EPSS 0,93%Нет опубликованного исправления

    Apache Thrift: Swift Compact Protocol integer overflow

    Integer Overflow or Wraparound vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Опубликовано Обновлено
  4. CVE-2026-41604

    Высокий · CVSS 8.2EPSS 0,92%Нет опубликованного исправления

    Apache Thrift: Swift Range crash in skip()

    Out-of-bounds Read vulnerability in Apache Thrift. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Опубликовано Обновлено
  5. CVE-2026-41602

    Высокий · CVSS 7.5EPSS 1,16%Нет опубликованного исправления

    Apache Thrift: Go TFramedTransport uint32 overflow

    Integer Overflow or Wraparound vulnerability in Apache Thrift TFramedTransport Go language implementation This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue.

    Опубликовано Обновлено
  6. CVE-2025-48431

    Высокий · CVSS 7.5EPSS 1,04%Нет опубликованного исправления

    Apache Thrift: Specially crafted input can crash a c_glib Thrift server with invalid pointer error.

    Mismatched Memory Management Routines vulnerability in Apache Thrift c_glib language bindings. This issue affects Apache Thrift: before 0.23.0. Users are recommended to upgrade to version 0.23.0, which fixes the issue. Description: Specially crafted requests can crash an c_glib-based Thrift server with a clean but fatal "free(): invalid pointer" error message.

    Опубликовано Обновлено
  7. CVE-2020-13949

    Высокий · CVSS 7.5EPSS 6,78%Есть исправление

    CVE-2020-13949

    In Apache Thrift 0.9.3 to 0.13.0, malicious RPC clients could send short messages which would result in a large memory allocation, potentially leading to denial of service.

    • Обновитесь до 0.16.0-3
    Опубликовано Обновлено
  8. CVE-2019-0205

    Высокий · CVSS 7.5EPSS 9,16%Публичный эксплойтЕсть исправление

    CVE-2019-0205

    In Apache Thrift all versions up to and including 0.12.0, a server or client may run into an endless loop when feed with specific input data. Because the issue had already been partially fixed in version 0.11.0, depending on the installed version it affects only certain language bindings.

    • Обновитесь до 0.13.0-2
    Опубликовано Обновлено
  9. CVE-2019-0210

    Высокий · CVSS 7.5EPSS 6,53%Есть исправление

    CVE-2019-0210

    In Apache Thrift 0.9.3 to 0.12.0, a server implemented in Go using TJSONProtocol or TSimpleJSONProtocol may panic when feed with invalid input data.

    • Обновитесь до 0.13.0-2
    Опубликовано Обновлено
  10. CVE-2018-11798

    Средний · CVSS 6.5EPSS 4,71%Есть исправление

    CVE-2018-11798

    The Apache Thrift Node.js static web server in versions 0.9.2 through 0.11.0 have been determined to contain a security vulnerability in which a remote user has the ability to access files outside the set webservers docroot path.

    • Обновитесь до 0.11.0-4
    Опубликовано Обновлено
  11. CVE-2016-5397

    Высокий · CVSS 8.8EPSS 6,87%Есть исправление

    CVE-2016-5397

    The Apache Thrift Go client library exposed the potential during code generation for command injection due to using an external formatting tool. Affected Apache Thrift 0.9.3 and older, Fixed in Apache Thrift 0.10.0.

    • Обновитесь до 0.11.0-3
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →