p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости pdns-recursor · Страница 2

За последние 30 дней в pdns-recursor опубликовано уязвимостей: 7; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 75

  1. CVE-2026-33260

    Средний · CVSS 5.3EPSS 0,52%Есть исправление

    Insufficient input validation of internal webserver

    An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default.

    • Обновитесь до 5.3.0-1
    Опубликовано Обновлено
  2. CVE-2026-33259

    Средний · CVSS 5EPSS 0,22%Есть исправление

    Concurrent modification of RPZ data can lead to denial of servce

    Having many concurrent transfers of the same RPZ can lead to inconsistent RPZ data, use after free and/or a crash of the recursor. Normally concurrent transfers of the same RPZ zone can only occur with a malfunctioning RPZ provider.

    • Обновитесь до 5.4.1-1
    Опубликовано Обновлено
  3. CVE-2026-33258

    Средний · CVSS 5.3EPSS 0,58%Есть исправление

    Crafted zones can cause increased resource usage

    By publishing and querying a crafted zone an attacker can cause allocation of large entries in the negative and aggressive NSEC(3) caches.

    • Обновитесь до 5.4.1-1
    Опубликовано Обновлено
  4. CVE-2026-33257

    Средний · CVSS 5.3EPSS 0,51%Есть исправление

    Insufficient input validation of internal webserver

    An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default.

    • Обновитесь до 5.3.0-1
    Опубликовано Обновлено
  5. CVE-2026-33256

    Средний · CVSS 5.3EPSS 0,61%Есть исправление

    Unbounded memory allocation by internal web server

    An attacker can send a web request that causes unlimited memory allocation in the internal web server, leading to a denial of service. The internal web server is disabled by default.

    • Обновитесь до 5.4.1-1
    Опубликовано Обновлено
  6. CVE-2026-33601

    Средний · CVSS 4.4EPSS 0,51%Есть исправление

    Insufficient validation of zonemd record

    If you use the zoneToCache function with a malicious authoritative server, an attacker can send a zone that result in a null pointer dereference, caused by a missing consistency check and leading to a denial of service.

    • Обновитесь до 5.4.1-1
    Опубликовано Обновлено
  7. CVE-2026-33600

    Средний · CVSS 4.4EPSS 0,52%Есть исправление

    Null pointer dereference in RPZ transfer

    An RPZ sent by a malicious authoritative server can result in a null pointer dereference, caused by a missing consistency check and leading to a denial of service.

    • Обновитесь до 5.4.1-1
    Опубликовано Обновлено
  8. CVE-2026-0398

    Средний · CVSS 5.3EPSS 0,34%Есть исправление

    Crafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in Recursor

    Crafted zones can lead to increased resource usage and crafted CNAME chains can lead to cache poisoning in Recursor.

    • Обновитесь до 5.3.5-1
    Опубликовано Обновлено
  9. CVE-2025-59029

    Средний · CVSS 5.3EPSS 0,37%Есть исправление

    Internal logic flaw in cache management can lead to a denial of service in PowerDNS Recursor

    An attacker can trigger an assertion failure by requesting crafted DNS records, waiting for them to be inserted into the records cache, then send a query with qtype set to ANY.

    • Обновитесь до 5.3.3-1
    Опубликовано Обновлено
  10. CVE-2025-59030

    Высокий · CVSS 7.5EPSS 0,58%Есть исправление

    Insufficient validation of incoming notifies over TCP can lead to a denial of service in Recursor

    An attacker can trigger the removal of cached records by sending a NOTIFY query over TCP.

    • Обновитесь до 5.3.3-1
    Опубликовано Обновлено
  11. CVE-2025-30192

    Высокий · CVSS 7.5EPSS 0,27%Есть исправление

    A Recursor configured to send out ECS enabled queries can be sensitive to spoofing attempts

    An attacker spoofing answers to ECS enabled requests sent out by the Recursor has a chance of success higher than non-ECS enabled queries. The updated version include various mitigations against spoofing attempts of ECS enabled queries by chaining ECS enabled requests and enforcing stricter validation of the received answers. The most strict mitigation done when the new setting outgoing.edns_subnet_harden (old style name edns-subnet-harden) is enabled.

    • Обновитесь до 5.2.4-2
    Опубликовано Обновлено
  12. CVE-2025-30195

    Высокий · CVSS 7.5EPSS 0,78%Есть исправление

    A crafted zone can lead to an illegal memory access in the PowerDNS Recursor

    An attacker can publish a zone containing specific Resource Record Sets. Processing and caching results for these sets can lead to an illegal memory accesses and crash of the Recursor, causing a denial of service. The remedy is: upgrade to the patched 5.2.1 version. We would like to thank Volodymyr Ilyin for bringing this issue to our attention.

    • Обновитесь до 5.2.1-1
    Опубликовано Обновлено
  13. CVE-2024-25590

    Высокий · CVSS 7.5EPSS 0,7%Есть исправление

    Crafted responses can lead to a denial of service due to cache inefficiencies in the Recursor

    An attacker can publish a zone containing specific Resource Record Sets. Repeatedly processing and caching results for these sets can lead to a denial of service.

    • Обновитесь до 5.0.9-1
    Опубликовано Обновлено
  14. CVE-2024-25583

    Высокий · CVSS 7.5EPSS 0,83%Есть исправление

    Crafted responses can lead to a denial of service in Recursor if recursive forwarding is configured

    A crafted response from an upstream server the recursor has been configured to forward-recurse to can cause a Denial of Service in the Recursor. The default configuration of the Recursor does not use recursive forwarding and is not affected.

    • Обновитесь до 4.9.5-1
    Опубликовано Обновлено
  15. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 4.9.3-1
    Опубликовано Обновлено
  16. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 4.9.3-1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →