p PatchFirst

GHSA-3wqh-h42r-x8fq

GHSA-3wqh-h42r-x8fq · Denial of Service in @hapi/content

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Versions of `@hapi/content` prior to 4.1.1 and 5.0.1 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services. ## Recommendation Upgrade to version 5.0.2. Versions 4.1.1 and 5.0.1 are fixed but only available for direct download through the repository.

Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • @hapi/content npm

    Затронутые диапазоны версий
    • SEMVER: < 5.0.2

    Обновитесь до 5.0.2

Первоисточники

Проверьте свой сервер →