p PatchFirst

GHSA-54xq-cgqr-rpm3

GHSA-54xq-cgqr-rpm3 · sharp vulnerability in libwebp dependency CVE-2023-4863

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

## Overview sharp uses libwebp to decode WebP images and versions prior to the latest 0.32.6 are vulnerable to the high severity https://github.com/advisories/GHSA-j7hp-h8jx-5ppr. ## Who does this affect? Almost anyone processing untrusted input with versions of sharp prior to 0.32.6. ## How to resolve this? ### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest 0.32.6, which provides libwebp 1.3.2. ### Using a globally-installed libvips? Please ensure you are using the latest libwebp 1.3.2. ## Possible workaround Add the following to your code to prevent sharp from decoding WebP images. ```js sharp.block({ operation: ["VipsForeignLoadWebp"] }); ```

CVSS 7.8 · Высокий · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • sharp npm

    Затронутые диапазоны версий
    • SEMVER: < 0.32.6

    Обновитесь до 0.32.6

Первоисточники

Проверьте свой сервер →