p PatchFirst

GHSA-5vj8-3v2h-h38v

GHSA-5vj8-3v2h-h38v · Remote Code Execution in next

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Versions of `next` prior to 5.1.0 are vulnerable to Remote Code Execution. The `/path:` route fails to properly sanitize input and passes it to a `require()` call. This allows attackers to execute JavaScript code on the server. Note that prior version 0.9.9 package `next` npm package hosted a different utility (0.4.1 being the latest version of that codebase), and this advisory does not apply to those versions. ## Recommendation Upgrade to version 5.1.0.

Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.9.9, < 5.1.0

    Обновитесь до 5.1.0

Первоисточники

Проверьте свой сервер →