GHSA-65v7-wg35-2qpm
GHSA-65v7-wg35-2qpm · Sylius Resource Bundle Cross-Site Request Forgery vulnerability
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Sylius 1.0.0 to 1.0.16, 1.1.0 to 1.1.8, 1.2.0 to 1.2.1 versions of AdminBundle and ResourceBundle are affected by this security issue. This issue has been fixed in Sylius 1.0.17, 1.1.9 and 1.2.2. Development branch for 1.3 release has also been fixed. ### Description The following actions in the admin panel did not require a CSRF token: - marking order’s payment as completed - marking order’s payment as refunded - marking product review as accepted - marking product review as rejected ### Resolution The issue is fixed by adding a required CSRF token to those actions. We also fixed `ResourceController`‘s `applyStateMachineTransitionAction` method by adding a CSRF token check. If you use that action in the API context, you can disable it by adding `csrf_protection:` false to its routing configuration
CVSS 6.5 · Средний · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
sylius/resource-bundle Packagist
- Версии
- v1.0.0
- v1.0.1
- v1.0.10
- v1.0.11
- v1.0.12
- v1.0.13
- v1.0.14
- v1.0.15
- v1.0.16
- v1.0.2
- v1.0.3
- v1.0.4
- v1.0.5
- v1.0.6
- v1.0.7
- v1.0.8
- v1.0.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 1.0.0, < 1.0.17
Обновитесь до 1.0.17
sylius/resource-bundle Packagist
- Версии
- v1.1.0
- v1.1.1
- v1.1.2
- v1.1.3
- v1.1.4
- v1.1.5
- v1.1.6
- v1.1.7
- v1.1.8
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 1.1.0, < 1.1.9
Обновитесь до 1.1.9
sylius/resource-bundle Packagist
- Версии
- v1.2.0
- v1.2.1
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 1.2.0, < 1.2.2
Обновитесь до 1.2.2
Первоисточники
- https://github.com/Sylius/SyliusResourceBundle/commit/9720ac5a0a39ea2c2a395ef16a94a00aa86c418b
- https://github.com/FriendsOfPHP/security-advisories/blob/master/sylius/sylius/2018-07-09.yaml
- https://github.com/Sylius/SyliusResourceBundle
- https://sylius.com/blog/csrf-vulnerability-in-admin-panel
- https://osv.dev/vulnerability/GHSA-65v7-wg35-2qpm