p PatchFirst

GHSA-7fjv-25q9-2w88

GHSA-7fjv-25q9-2w88 · State Guessing Vulnerability in laravel/socialite

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

laravel/socialite versions prior to 2.0.10 are susceptible to a security vulnerability related to state guessing during OAuth authentication. This vulnerability could potentially lead to session hijacking, allowing attackers to compromise user sessions. The issue has been addressed and fixed in version 2.0.10.

Есть исправление

Опубликовано
Обновлено

Стек: php

Затронутые продукты и версии

  • laravel/socialite Packagist

    Версии
    • v1.0.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v2.0.0
    • v2.0.1
    • v2.0.2
    • v2.0.3
    • v2.0.4
    • v2.0.5
    • v2.0.6
    • v2.0.7
    • v2.0.8
    • v2.0.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.0.0, < 2.0.10

    Обновитесь до 2.0.10

Первоисточники

Проверьте свой сервер →