GHSA-98j6-67v3-mw34
GHSA-98j6-67v3-mw34 · Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
**Overview** The Auth0 Symfony SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. **Am I Affected?** You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 Symfony SDK, versions between 5.0.0 BETA-0 to 5.0.0. 2. Auth0 Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. **Fix** Upgrade Auth0/symfony to the latest version (v5.4.0). **Acknowledgement** Okta would like to thank Andreas Forsblom for discovering this vulnerability.
CVSS 9.3 · Критический · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
auth0/symfony Packagist
- Версии
- 5.0.0
- 5.0.0-BETA0
- 5.0.0-BETA1
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 5.0.0-BETA0, < 5.1.0
Обновитесь до 5.1.0
Первоисточники
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-v9m8-9xxp-q492
- https://github.com/auth0/laravel-auth0/security/advisories/GHSA-c42h-56wx-h85q
- https://github.com/auth0/symfony/security/advisories/GHSA-98j6-67v3-mw34
- https://github.com/auth0/wordpress/security/advisories/GHSA-862m-5253-832r
- https://nvd.nist.gov/vuln/detail/CVE-2025-48951
- https://github.com/auth0/symfony
- https://osv.dev/vulnerability/GHSA-98j6-67v3-mw34