GHSA-f3r2-88mq-9v4g
GHSA-f3r2-88mq-9v4g · Auth0 Symfony SDK has Improper Audience Validation via Auth0-PHP SDK
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
### Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. ### Affected product and versions Projects are affected if they meet the following preconditions: - Applications using the Auth0 Symfony SDK with versions between 5.0.0 and 5.5.0 - Auth0 Symfony SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. ### Resolution Upgrade Auth0/symfony to version 5.6.0 or greater. ### Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
CVSS 6.8 · Средний · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
auth0/symfony Packagist
- Версии
- 5.0.0
- 5.1.0
- 5.2.0
- 5.2.1
- 5.2.2
- 5.2.3
- 5.3.0
- 5.3.1
- 5.4.0
- 5.4.1
- 5.5.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 5.0.0, < 5.6.0
Обновитесь до 5.6.0