p PatchFirst

GHSA-g9jg-w8vm-g96v

GHSA-g9jg-w8vm-g96v · Trix has a stored XSS vulnerability through its attachment attribute

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

### Impact The Trix editor, in versions prior to 2.1.16, is vulnerable to XSS attacks through attachment payloads. An attacker could inject malicious code into a data-trix-attachment attribute that, when rendered as HTML and clicked on, could execute arbitrary JavaScript code within the context of the user's session, potentially leading to unauthorized actions being performed or sensitive information being disclosed. ### Patches Update Recommendation: Users should upgrade to Trix editor version 2.1.16 or later. ### Resources The XSS vulnerability was reported by HackerOne researcher [michaelcheers](https://hackerone.com/michaelcheers?type=user).

CVSS 4.6 · Средний · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • trix npm

    Затронутые диапазоны версий
    • SEMVER: < 2.1.16

    Обновитесь до 2.1.16

  • action_text-trix RubyGems

    Версии
    • 0.0.1
    • 2.1.15
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.1.16

    Обновитесь до 2.1.16

Первоисточники

Проверьте свой сервер →