p PatchFirst

GHSA-pp84-v3mw-gg4w

GHSA-pp84-v3mw-gg4w · Taipy 3.1.1 affected by CVEs on flask-core and pymongo

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

### Summary Indirect CVEs affect Taipy 3.1.1 ### Details Taipy 3.1.1 is affected by two existing CVEs: CVE-2024-1681 affects flask-core <4.0.1 and taipy 3.1.1 needs <=4.0.0 CVE-2024-5629 affects pymongo <4.6.3 and taipy 3.1.1 needs <=4.6.1 Please see References for further details. ### Patch please upgrade to the following versions: Fixed on patch versions: >=3.1.2 and on major releases: >=4.0.0 ### Impact pre-commit breaks when using dependency Taipy 3.1.1

Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • taipy PyPI

    Версии
    • 1.0.0
    • 1.1.0
    • 2.0.0
    • 2.1.0
    • 2.2.0
    • 2.3.0
    • 2.3.1
    • 2.4.0
    • 3.0.0
    • 3.1.0
    • 3.1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.0.0

    Обновитесь до 4.0.0

Первоисточники

Проверьте свой сервер →