p PatchFirst

GHSA-q2c6-c6pm-g3gh

GHSA-q2c6-c6pm-g3gh · Arbitrary Code Execution in handlebars

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Versions of `handlebars` prior to 3.0.8 or 4.5.3 are vulnerable to Arbitrary Code Execution. The package's lookup helper fails to properly validate templates, allowing attackers to submit templates that execute arbitrary JavaScript in the system. It is due to an incomplete fix for a [previous issue](https://www.npmjs.com/advisories/1316). This vulnerability can be used to run arbitrary code in a server processing Handlebars templates or on a victim's browser (effectively serving as Cross-Site Scripting). ## Recommendation Upgrade to version 3.0.8, 4.5.3 or later.

Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • handlebars npm

    Затронутые диапазоны версий
    • SEMVER: < 3.0.8

    Обновитесь до 3.0.8

  • handlebars npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.5.3

    Обновитесь до 4.5.3

Первоисточники

Проверьте свой сервер →