p PatchFirst

GHSA-wfm2-rq5g-f8v5

GHSA-wfm2-rq5g-f8v5 · @account-kit/smart-contracts Allowlist Module Bypass Vulnerability

CVSS 8.7 · Высокий · Есть исправление

Затронуты ли вы?

Как узнать установленную версию:

npm ls @account-kit/smart-contracts

Бесплатная проверка подсветит, требует ли внимания @account-kit/smart-contracts и остальные зависимости: проверьте lock-файл проекта или весь сервер командой ниже. Без регистрации. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить зависимости бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

### Summary Allowlist module contains a bypass vulnerability ### Details The logic for using an allowlist on a Modular Account V2 contained a bug that allowed session keys to bypass any allowlist configuration ### Action If you are using @aa-sdk and/or @account-kit/smart-contracts between the versions of >=4.8.0 and <4.28.1, please upgrade to 4.28.2

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • @account-kit/smart-contracts npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.8.0, < 4.28.2

    Обновитесь до 4.28.2

Первоисточники

Проверьте свой сервер →