p PatchFirst

PatchFirst · Свежие уязвимости

concrete5/concrete5 9.5.0: известные уязвимости · Страница 3

Известных уязвимостей, затрагивающих concrete5/concrete5 9.5.0: 46. Сравните исправленные версии ниже с установленной у вас.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 46

  1. CVE-2026-8428

    Высокий · CVSS 7.5EPSS 0,13%Есть исправление

    CSRF token is not validated in the core CMS update controller for Concrete CMS 9.5.0 and below

    Concrete CMS 9.5.0 and below emits a CSRF token in the local_available_update.php view ($token->output('do_update')) but the corresponding do_update() method in concrete/controllers/single_page/dashboard/system/update/update.php never calls $this->token->validate('do_update'). The form is rendered as a POST form, meaning the token reaches the browser, but because the controller discards it without verification, an attacker can craft a cross-site POST that triggers a core CMS update to an attacker-specified version string.  In order to be vulnerable, theictim must be passing canUpgrade()anda valid update version must be present under DIR_CORE_

    • Обновитесь до 9.5.1
    Опубликовано Обновлено
  2. CVE-2026-8426

    Высокий · CVSS 7.5EPSS 0,17%Есть исправление

    Concrete CMS 9.5.0 and below is vulnerable to CSRF on prepare_remote_upgrade() leading to one-request RCE via package overwrite

    Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/prepare_remote_upgrade/<remoteMPID>. An attacker who controls the remote package returned for a known marketplace item ID can overwrite the package PHP on disk and force its upgrade() method to execute in a single browser navigation. This results in remote code execution as the web server user.   In order to be vulnerable, the victim must be passing canInstallPackages, victim site must be connected to the Concrete marketplace; and the attacker controls the package returned for a marketplace item ID already installed on the victim

    • Обновитесь до 9.5.1
    Опубликовано Обновлено
  3. CVE-2026-8140

    Высокий · CVSS 7.5EPSS 0,12%Есть исправление

    Concrete CMS 9.5.0 and below is vulnerable to CSRF on download() in the package install controller

    Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/install/download/<remoteId>. The download() method in concrete/controllers/single_page/dashboard/extend/install.php checks only the canInstallPackages() permission before fetching a remote marketplace package and writing it to the server's DIR_PACKAGES directory. Because the endpoint is a state-changing GET route with no token enforcement, an attacker who can cause an authenticated administrator to visit a crafted page can force an arbitrary marketplace package to be downloaded. In order to be vulnerable, the victim must be passing canI

    • Обновитесь до 9.5.1
    Опубликовано Обновлено
  4. CVE-2026-8417

    Высокий · CVSS 7.5EPSS 0,12%Есть исправление

    Concrete CMS 9.5.0 and below is vulnerable to CSRF in do_update() in the package update controller

    Concrete CMS 9.5.0 and below does not validate a CSRF token before processing requests to /dashboard/extend/update/do_update/<pkgHandle>. The do_update() method in concrete/controllers/single_page/dashboard/extend/update.php checks only canInstallPackages() before executing upgradeCoreData() and upgrade() on the named package's controller. Because the endpoint is a state-changing GET route with no token enforcement, an attacker can force an authenticated administrator to trigger a package upgrade via a single cross-site navigation.In order to be vulnerable, the victim must be passing canInstallPackages() and and a target package must already

    • Обновитесь до 9.5.1
    Опубликовано Обновлено
  5. CVE-2026-8135

    Высокий · CVSS 8.9EPSS 0,47%Есть исправление

    Concrete CMS 9.5.0 and below is vulnerable to RCE due to insecure deserialization occurring in the ExpressEntryList block controller.

    Concrete CMS 9.5.0 and below is vulnerable to Remote Code Execution due to insecure deserialization occurring in the ExpressEntryList block controller. An rogue administrator with privileges to add blocks to an area can bypass the intended protection mechanism (_fromCIF === true), which normally restricts malicious inputs over form POST requests, by leveraging the REST API functionality. Because the REST API parses requests using json_decode(), the string "true" is evaluated as a strict PHP Boolean(true).  This bypass allows the attacker to inject a malicious serialized payload  into the block's filterFields database column. The payload will

    • Обновитесь до 9.5.1
    Опубликовано Обновлено
  6. CVE-2026-8134

    Критический · CVSS 9.4EPSS 0,74%Есть исправление

    Concrete CMS 9.5.0 and below is vulnerable to Authenticated RCE via Composer customTemplate Path Traversal leading to PHP File Inclusion

    Concrete CMS 9.5.0 and below fails to sanitize path traversal sequences in the ptComposerFormLayoutSetControlCustomTemplate field when saving page type composer form layouts. An authenticated rogue administrator with composer form editing rights can exploit this to include arbitrary readable files on the server. Combined with the file uploader's extension-only validation (which permits PHP code in files saved with image extensions like .png), this can result in authenticated remote code execution. The Concrete CMS security team gave this vulnerability a CVSS v.4.0 score of 9.4 with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/

    • Обновитесь до 9.5.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →