p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости contao/core-bundle · Страница 2

За последние 30 дней в contao/core-bundle опубликовано уязвимостей: 6; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 40

  1. CVE-2024-28235

    Высокий · CVSS 8.4EPSS 0,71%Есть исправление

    Contao possible cookie sharing with external domains while checking protected pages for broken links

    Contao is an open source content management system. Starting in version 4.9.0 and prior to versions 4.13.40 and 5.3.4, when checking for broken links on protected pages, Contao sends the cookie header to external urls as well, the passed options for the http client are used for all requests. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, disable crawling protected pages.

    • Обновитесь до 4.13.40
    • Обновитесь до 5.3.4
    Опубликовано Обновлено
  2. CVE-2024-28191

    Низкий · CVSS 3.1EPSS 0,5%Есть исправление

    Contao may have unencoded insert tags in the frontend

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, it is possible to inject insert tags in frontend forms if the output is structured in a very specific way. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, do not output user data from frontend forms next to each other, always separate them by at least one character.

    • Обновитесь до 4.13.40
    • Обновитесь до 5.3.4
    Опубликовано Обновлено
  3. CVE-2024-28190

    Средний · CVSS 5.4EPSS 0,5%Есть исправление

    Contao core bundle vulnerable to cross site scripting in the file manager

    Contao is an open source content management system. Starting in version 4.0.0 and prior to version 4.13.40 and 5.3.4, users can inject malicious code in filenames when uploading files (back end and front end), which is then executed in tooltips and popups in the back end. Contao versions 4.13.40 and 5.3.4 have a patch for this issue. As a workaround, remove upload fields from frontend forms and disable uploads for untrusted back end users.

    • Обновитесь до 4.13.40
    • Обновитесь до 5.3.4
    Опубликовано Обновлено
  4. CVE-2023-36806

    Средний · CVSS 6.5EPSS 0,64%Есть исправление

    Contao cross site scripting vulnerability via input unit widget

    Contao is an open source content management system. Starting in version 4.0.0 and prior to versions 4.9.42, 4.13.28, and 5.1.10, it is possible for untrusted backend users to inject malicious code into headline fields in the back end, which will be executed both in the element preview (back end) and on the website (front end). Installations are only affected if there are untrusted back end users who have the rights to modify headline fields, or other fields using the input unit widget. Contao 4.9.42, 4.13.28, and 5.1.10 have a patch for this issue. As a workaround, disable the login for all untrusted back end users.

    • Обновитесь до 4.13.28
    • Обновитесь до 4.9.42
    • Обновитесь до 5.1.10
    Опубликовано Обновлено
  5. CVE-2022-24899

    Высокий · CVSS 7.2EPSS 4,48%Публичный эксплойтЕсть исправление

    Cross site scripting via canonical tag

    Contao is a powerful open source CMS that allows you to create professional websites and scalable web applications. In versions of Contao prior to 4.13.3 it is possible to inject code into the canonical tag. As a workaround users may disable canonical tags in the root page settings.

    • Обновитесь до 4.13.3
  6. CVE-2021-35955

    Средний · CVSS 5.9EPSS 0,56%Есть исправление

    CVE-2021-35955

    Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.

    • Обновитесь до 4.11.7
    • Обновитесь до 4.4.56
    • Обновитесь до 4.9.18
    Опубликовано Обновлено
  7. CVE-2021-37627

    Высокий · CVSS 8EPSS 1,02%Есть исправление

    Privilege escalation via form generator

    Contao is an open source CMS that allows creation of websites and scalable web applications. In affected versions it is possible to gain privileged rights in the Contao back end. Installations are only affected if they have untrusted back end users who have access to the form generator. All users are advised to update to Contao 4.4.56, 4.9.18 or 4.11.7. As a workaround users may disable the form generator or disable the login for untrusted back end users.

    • Обновитесь до 4.11.7
    • Обновитесь до 4.4.56
    • Обновитесь до 4.9.18
    Опубликовано Обновлено
  8. CVE-2021-37626

    Высокий · CVSS 7.2EPSS 1,25%Есть исправление

    PHP file inclusion via insert tags

    Contao is an open source CMS that allows you to create websites and scalable web applications. In affected versions it is possible to load PHP files by entering insert tags in the Contao back end. Installations are only affected if they have untrusted back end users who have the rights to modify fields that are shown in the front end. Update to Contao 4.4.56, 4.9.18 or 4.11.7 to resolve. If you cannot update then disable the login for untrusted back end users.

    • Обновитесь до 4.11.7
    • Обновитесь до 4.4.56
    • Обновитесь до 4.9.18
    Опубликовано Обновлено
  9. CVE-2021-35210

    Средний · CVSS 6.1EPSS 0,74%Есть исправление

    CVE-2021-35210

    Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.

    • Обновитесь до 4.11.5
    • Обновитесь до 4.9.16
  10. CVE-2020-25768

    Средний · CVSS 5.3EPSS 0,82%Есть исправление

    CVE-2020-25768

    Contao before 4.4.52, 4.9.x before 4.9.6, and 4.10.x before 4.10.1 have Improper Input Validation. It is possible to inject insert tags in front end forms which will be replaced when the page is rendered.

    • Обновитесь до 4.10.1
    • Обновитесь до 4.4.52
    • Обновитесь до 4.9.6
    Опубликовано Обновлено
  11. CVE-2019-19745

    Высокий · CVSS 8.8EPSS 1,11%Есть исправление

    CVE-2019-19745

    Contao 4.0 through 4.8.5 allows PHP local file inclusion. A back end user with access to the form generator can upload arbitrary files and execute them on the server.

    • Обновитесь до 4.4.46
    • Обновитесь до 4.8.6
    Опубликовано Обновлено
  12. CVE-2019-19714

    Средний · CVSS 5.3EPSS 0,82%Есть исправление

    CVE-2019-19714

    Contao 4.8.4 and 4.8.5 has Improper Encoding or Escaping of Output. It is possible to inject insert tags into the login module which will be replaced when the page is rendered.

    • Обновитесь до 4.8.6
    Опубликовано Обновлено
  13. CVE-2019-19712

    Средний · CVSS 5.3EPSS 0,88%Есть исправление

    CVE-2019-19712

    Contao 4.0 through 4.8.5 has Insecure Permissions. Back end users can manipulate the details view URL to show pages and articles that have not been enabled for them.

    • Обновитесь до 4.4.46
    • Обновитесь до 4.8.6
    Опубликовано Обновлено
  14. CVE-2017-16558

    Критический · CVSS 9.8EPSS 1,51%Есть исправление

    CVE-2017-16558

    Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the back end as well as in the listing module.

    • Обновитесь до 4.4.8
    Опубликовано Обновлено
  15. CVE-2019-10641

    Критический · CVSS 9.8EPSS 1,34%Есть исправление

    CVE-2019-10641

    Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password.

    • Обновитесь до 4.4.37
    • Обновитесь до 4.7.3
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →