p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости shopware/shopware · Страница 2

За последние 30 дней в shopware/shopware опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 34

  1. CVE-2021-32712

    Средний · CVSS 5.3EPSS 1,14%Есть исправление

    Information leakage in Error Handler

    Shopware is an open source eCommerce platform. Versions prior to 5.6.10 are vulnerable to system information leakage in error handling. Users are recommend to update to version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview.

    • Обновитесь до 5.6.10
  2. CVE-2021-32713

    Средний · CVSS 4.8EPSS 0,73%Есть исправление

    Authenticated Stored XSS

    Shopware is an open source eCommerce platform. Versions prior to 5.6.10 suffer from an authenticated stored XSS in administration vulnerability. Users are recommend to update to the version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview.

    • Обновитесь до 5.6.10
  3. GHSA-9vxv-wpv4-f52p

    Без оценкиЕсть исправление

    Information leakage in Error Handler

    ### Impact Information leakage in Error Handler ### Patches We recommend updating to the current version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview. For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-05-2021

    • Обновитесь до 5.6.10
    Опубликовано Обновлено
  4. GHSA-f6p7-8xfw-fjqq

    Без оценкиЕсть исправление

    Authenticated Stored XSS in Administration

    ### Impact Authenticated Stored XSS in Administration ### Patches We recommend updating to the current version 5.6.10. You can get the update to 5.6.10 regularly via the Auto-Updater or directly via the download overview. For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-05-2021

    • Обновитесь до 5.6.10
  5. GHSA-3pcr-4982-548m

    Без оценкиЕсть исправление

    Exposure of .env if project root is configured as web root in shopware/production

    ### Impact The .env and other sensitive files can be leaked if the project root and not `/public` is configured as the web root. ### Patches We recommend to update to the current version 6.3.5.3. You can get the update to 6.3.5.3 regularly via the Auto-Updater or directly via the download overview. https://www.shopware.com/en/download/#shopware-6 ### Workarounds You should always use `/public` as the web root. For older versions of 6.1 and 6.2, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version. https://store.shopware.com/en/detail/index

    • Обновитесь до 6.3.5.3
    Опубликовано Обновлено
  6. GHSA-hrfh-fp4x-crrq

    Без оценкиЕсть исправление

    Persistent XSS in newsletter module in Shopware

    ### Impact Persistent XSS in newsletter module ### Patches We recommend updating to the current version 5.6.9. You can get the update to 5.6.9 regularly via the Auto-Updater or directly via the download overview. For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-11-2020

    • Обновитесь до 5.6.9
    Опубликовано Обновлено
  7. GHSA-28fw-88hq-6jmm

    Без оценкиЕсть исправление

    Persistent XSS in shopping worlds

    ### Impact Persistent XSS in shopping worlds ### Patches We recommend updating to the current version 5.6.9. You can get the update to 5.6.9 regularly via the Auto-Updater or directly via the download overview. For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-11-2020

    • Обновитесь до 5.6.9
    Опубликовано Обновлено
  8. GHSA-6gv9-7q4g-pmvm

    Без оценкиЕсть исправление

    Persistent XSS in customer module in Shopware

    ### Impact Persistent XSS in customer module ### Patches We recommend updating to the current version 5.6.9. You can get the update to 5.6.9 regularly via the Auto-Updater or directly via the download overview. For older versions you can use the Security Plugin: https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html ### References https://docs.shopware.com/en/shopware-5-en/security-updates/security-update-11-2020

    • Обновитесь до 5.6.9
    Опубликовано Обновлено
  9. CVE-2019-12799

    Средний · CVSS 6.5EPSS 54,05%Публичный эксплойтНет опубликованного исправления

    CVE-2019-12799

    In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can trigger a PHP object instantiation vulnerability, which can result in an arbitrary deserialization if the right class is instantiated. An attacker can leverage this deserialization to achieve remote code execution. NOTE: this issue is a bypass for a CVE-2017-18357 whitelist patch.

    Опубликовано Обновлено
  10. CVE-2017-18357

    Средний · CVSS 6.5EPSS 27,07%Публичный эксплойтЕсть исправление

    CVE-2017-18357

    Shopware before 5.3.4 has a PHP Object Instantiation issue via the sort parameter to the loadPreviewAction() method of the Shopware_Controllers_Backend_ProductStream controller, with resultant XXE via instantiation of a SimpleXMLElement object.

    • Обновитесь до 5.3.4
    Опубликовано Обновлено
  11. CVE-2017-15374

    Средний · CVSS 6.1EPSS 4,81%Публичный эксплойтНет опубликованного исправления

    CVE-2017-15374

    Shopware v5.2.5 - v5.3 is vulnerable to cross site scripting in the customer and order section of the content management system backend modules. Remote attackers are able to inject malicious script code into the firstname, lastname, or order input fields to provoke persistent execution in the customer and orders section of the backend. The execution occurs in the administrator backend listing when processing a preview of the customers (kunden) or orders (bestellungen). The injection can be performed interactively via user registration or by manipulation of the order information inputs. The issue can be exploited by low privileged user account

    Опубликовано Обновлено
  12. CVE-2016-3109

    Критический · CVSS 9.8EPSS 28,11%Есть исправление

    CVE-2016-3109

    The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code.

    • Обновитесь до 4.3.7
    • Обновитесь до 5.1.5
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →