p PatchFirst

SUSE-SU-2022:2826-1

SUSE-SU-2022:2826-1 · Security update for webkit2gtk3

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

This update for webkit2gtk3 fixes the following issues: - Update to version 2.36.5 (bsc#1201980): - Add support for PAC proxy in the WebDriver implementation. - Fix video playback when loaded through custom URIs, this fixes video playback in the Yelp documentation browser. - Fix WebKitWebView::context-menu when using GTK4. - Fix LTO builds with GCC. - Fix several crashes and rendering issues. - Security fixes: - CVE-2022-32792: Fixed processing maliciously crafted web content may lead to arbitrary code execution. - CVE-2022-32816: Fixed visiting a website that frames malicious content may lead to UI spoofing.

Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.36.5-150400.4.9.1

    Обновитесь до 2.36.5-150400.4.9.1

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.36.5-150400.4.9.1

    Обновитесь до 2.36.5-150400.4.9.1

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.36.5-150400.4.9.1

    Обновитесь до 2.36.5-150400.4.9.1

  • webkit2gtk3 openSUSE:Leap 15.4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.36.5-150400.4.9.1

    Обновитесь до 2.36.5-150400.4.9.1

  • webkit2gtk3-soup2 openSUSE:Leap 15.4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.36.5-150400.4.9.1

    Обновитесь до 2.36.5-150400.4.9.1

  • webkit2gtk4 openSUSE:Leap 15.4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.36.5-150400.4.9.1

    Обновитесь до 2.36.5-150400.4.9.1

Первоисточники

Проверьте свой сервер →