p PatchFirst

SUSE-SU-2023:3419-1

SUSE-SU-2023:3419-1 · Security update for webkit2gtk3

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

This update for webkit2gtk3 fixes the following issues: Update to version 2.40.5 (bsc#1213905): - CVE-2023-38133: Fixed information disclosure. - CVE-2023-38572: Fixed Same-Origin-Policy bypass. - CVE-2023-38592: Fixed arbitrary code execution. - CVE-2023-38594: Fixed arbitrary code execution. - CVE-2023-38595: Fixed arbitrary code execution. - CVE-2023-38597: Fixed arbitrary code execution. - CVE-2023-38599: Fixed sensitive user information tracking. - CVE-2023-38600: Fixed arbitrary code execution. - CVE-2023-38611: Fixed arbitrary code execution. Update to version 2.40.3 (bsc#1212863): - CVE-2023-32439: Fixed a bug where processing maliciously crafted web content may lead to arbitrary code execution. (bsc#1212863) - CVE-2023-32435: Fixed a bug where processing web content may lead to arbitrary code execution. (bsc#1212863) - CVE-2022-48503: Fixed a bug where processing web content may lead to arbitrary code execution. (bsc#1212863)

Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3 openSUSE:Leap 15.4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3-soup2 openSUSE:Leap 15.4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk4 openSUSE:Leap 15.4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3 openSUSE:Leap 15.5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk3-soup2 openSUSE:Leap 15.5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

  • webkit2gtk4 openSUSE:Leap 15.5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.40.5-150400.4.45.3

    Обновитесь до 2.40.5-150400.4.45.3

Первоисточники

Проверьте свой сервер →