p PatchFirst

SUSE-SU-2024:0548-1

SUSE-SU-2024:0548-1 · Security update for webkit2gtk3

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

This update for webkit2gtk3 fixes the following issues: Update to version 2.42.5 (bsc#1219604): - CVE-2024-23222: Fixed processing maliciously crafted web content that may have led to arbitrary code execution (bsc#1219113). - CVE-2024-23206: Fixed fingerprint user via maliciously crafted webpages (bsc#1219604). - CVE-2024-23213: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). - CVE-2023-40414: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604). - CVE-2014-1745: Fixed denial-of-service or potentially disclose memory contents while processing maliciously crafted files (bsc#1219604). - CVE-2023-42833: Fixed processing web content that may have led to arbitrary code execution (bsc#1219604).

Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Module for Basesystem 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3 SUSE:Linux Enterprise Module for Desktop Applications 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk4 SUSE:Linux Enterprise Module for Development Tools 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 SUSE:Manager Proxy 4.3

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 SUSE:Manager Server 4.3

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3 openSUSE:Leap 15.5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk3-soup2 openSUSE:Leap 15.5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

  • webkit2gtk4 openSUSE:Leap 15.5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.42.5-150400.4.75.1

    Обновитесь до 2.42.5-150400.4.75.1

Первоисточники

Проверьте свой сервер →