SUSE-SU-2024:2061-1
SUSE-SU-2024:2061-1 · Security update for MozillaFirefox
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
This update for MozillaFirefox fixes the following issues: - Update to version 115.12.0 ESR (bsc#1226027) - CVE-2024-5702: Use-after-free in networking - CVE-2024-5688: Use-after-free in JavaScript object transplant - CVE-2024-5690: External protocol handlers leaked by timing attack - CVE-2024-5691: Sandboxed iframes were able to bypass sandbox restrictions to open a new window - CVE-2024-5692: Bypass of file name restrictions during saving - CVE-2024-5693: Cross-Origin Image leak via Offscreen Canvas - CVE-2024-5696: Memory Corruption in Text Fragments - CVE-2024-5700: Memory safety bugs fixed in Firefox 127, Firefox ESR 115.12, and Thunderbird 115.12
Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
mozillafirefox SUSE:Linux Enterprise Module for Desktop Applications 15 SP5
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Module for Desktop Applications 15 SP6
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Server 15 SP2-LTSS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Server 15 SP3-LTSS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Server 15 SP4-LTSS
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Server for SAP Applications 15 SP2
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Server for SAP Applications 15 SP3
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Linux Enterprise Server for SAP Applications 15 SP4
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox SUSE:Enterprise Storage 7.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox openSUSE:Leap 15.5
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
mozillafirefox openSUSE:Leap 15.6
- Затронутые диапазоны версий
- ECOSYSTEM: < 115.12.0-150200.152.140.2
Обновитесь до 115.12.0-150200.152.140.2
Первоисточники
- https://www.suse.com/support/update/announcement/2024/suse-su-20242061-1/
- https://bugzilla.suse.com/1226027
- https://www.suse.com/security/cve/CVE-2024-5688
- https://www.suse.com/security/cve/CVE-2024-5690
- https://www.suse.com/security/cve/CVE-2024-5691
- https://www.suse.com/security/cve/CVE-2024-5692
- https://www.suse.com/security/cve/CVE-2024-5693
- https://www.suse.com/security/cve/CVE-2024-5696
- https://www.suse.com/security/cve/CVE-2024-5700
- https://www.suse.com/security/cve/CVE-2024-5702
- https://osv.dev/vulnerability/SUSE-SU-2024:2061-1