p PatchFirst

SUSE-SU-2025:1265-1

SUSE-SU-2025:1265-1 · Security update for webkit2gtk3

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

This update for webkit2gtk3 fixes the following issues: - Update to version 2.48.1 - CVE-2024-54551: improper memory handling may lead to a denial-of-service when processing certain web content (bsc#1240962) - CVE-2025-24208: permissions issue may lead to a cross-site scripting attack when loading a malicious iframe (bsc#1240961) - CVE-2025-24209: buffer overflow may lead to crash when processing maliciously crafted web content (bsc#1240964) - CVE-2025-24213: type confusion issue may lead to memory corruption (bsc#1240963) - CVE-2025-24216: improper memory handling may lead to an unexpected crash when processing certain web content (bsc#1240986) - CVE-2025-24264: improper memory handling may lead to unexpected crash when processing certain web content (bsc#1240987) - CVE-2025-30427: use-after-free issue may lead to an unexpected Safari crash when processing maliciously crafted web content (bsc#1240958)

Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.48.1-150200.142.1

    Обновитесь до 2.48.1-150200.142.1

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP3-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.48.1-150200.142.1

    Обновитесь до 2.48.1-150200.142.1

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP3

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.48.1-150200.142.1

    Обновитесь до 2.48.1-150200.142.1

  • webkit2gtk3 SUSE:Enterprise Storage 7.1

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.48.1-150200.142.1

    Обновитесь до 2.48.1-150200.142.1

Первоисточники

Проверьте свой сервер →