p PatchFirst

SUSE-SU-2025:4297-1

SUSE-SU-2025:4297-1 · Security update for python311

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

This update for python311 fixes the following issues: Update to 3.11.14: - CVE-2025-6075: Fixed simple quadratic complexity vulnerabilities of os.path.expandvars() (bsc#1252974) - CVE-2025-8291: Fixed validity of the ZIP64 End of Central Directory (EOCD) not checked by the 'zipfile' module (bsc#1251305)

Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • python311-core SUSE:Linux Enterprise Module for Basesystem 15 SP6

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311-core SUSE:Linux Enterprise Module for Basesystem 15 SP7

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP6

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP6

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311 SUSE:Linux Enterprise Module for Python 3 15 SP7

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311-core SUSE:Linux Enterprise Module for Python 3 15 SP7

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311 openSUSE:Leap 15.6

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311-core openSUSE:Leap 15.6

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

  • python311-documentation openSUSE:Leap 15.6

    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.11.14-150600.3.38.1

    Обновитесь до 3.11.14-150600.3.38.1

Первоисточники

Проверьте свой сервер →