p PatchFirst

SUSE-SU-2025:4527-1

SUSE-SU-2025:4527-1 · Security update for webkit2gtk3

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.

This update for webkit2gtk3 fixes the following issues: Update to version 2.50.4. Security issues fixed: - CVE-2025-14174: processing maliciously crafted web content may lead to memory corruption due to improper validation (bsc#1255497). - CVE-2025-43501: processing maliciously crafted web content may lead to an unexpected process crash due to a buffer overflow issue (bsc#1255194). - CVE-2025-43529: processing maliciously crafted web content may lead to arbitrary code execution due to a use-after-free issue (bsc#1255198). - CVE-2025-43531: processing maliciously crafted web content may lead to an unexpected process crash due to a race condition (bsc#1255183). - CVE-2025-43535: processing maliciously crafted web content may lead to an unexpected process crash due to improper memory handling (bsc#1255195). - CVE-2025-43536: processing maliciously crafted web content may lead to an unexpected process crash due to a use-after-free issue (bsc#1255200). - CVE-2025-43541: processing maliciously crafted web content may lead to an unexpected process crash due to type confusion (bsc#1255191). Other updates and bugfixes: - Version 2.50.4: * Correctly handle the program name passed to the sleep disabler. * Ensure GStreamer is initialized before using the Quirks. * Fix several crashes and rendering issues. - Fix a11y regression where AT-SPI roles were mapped incorrectly.

Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP4-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise Server 15 SP5-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server 15 SP5-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise Server 15 SP5-LTSS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP4

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3 SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

  • webkit2gtk3-soup2 SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.1

    Обновитесь до 2.50.4-150400.4.134.1

  • webkit2gtk4 SUSE:Linux Enterprise Server for SAP Applications 15 SP5

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.50.4-150400.4.134.2

    Обновитесь до 2.50.4-150400.4.134.2

Первоисточники

Проверьте свой сервер →