p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости gst-plugins-good0.10 · Страница 2

За последние 30 дней в gst-plugins-good0.10 опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 32

  1. CVE-2024-47539

    Высокий · CVSS 8.6EPSS 1,32%Нет опубликованного исправления

    GHSL-2024-195: GStreamer has an OOB-write in convert_to_s334_1a

    GStreamer is a library for constructing graphs of media-handling components. An out-of-bounds write vulnerability was identified in the convert_to_s334_1a function in isomp4/qtdemux.c. The vulnerability arises due to a discrepancy between the size of memory allocated to the storage array and the loop condition i * 2 < ccpair_size. Specifically, when ccpair_size is even, the allocated size in storage does not match the loop's expected bounds, resulting in an out-of-bounds write. This bug allows for the overwriting of up to 3 bytes beyond the allocated bounds of the storage array. This vulnerability is fixed in 1.24.10.

    Опубликовано Обновлено
  2. CVE-2024-47537

    Высокий · CVSS 8.6EPSS 0,96%Нет опубликованного исправления

    GHSL-2024-094: GStreamer has an OOB-write in isomp4/qtdemux.c

    GStreamer is a library for constructing graphs of media-handling components. The program attempts to reallocate the memory pointed to by stream->samples to accommodate stream->n_samples + samples_count elements of type QtDemuxSample. The problem is that samples_count is read from the input file. And if this value is big enough, this can lead to an integer overflow during the addition. As a consequence, g_try_renew might allocate memory for a significantly smaller number of elements than intended. Following this, the program iterates through samples_count elements and attempts to write samples_count number of elements, potentially exceeding th

    Опубликовано Обновлено
  3. CVE-2023-37327

    Высокий · CVSS 7.6EPSS 1,7%Нет опубликованного исправления

    GStreamer FLAC File Parsing Integer Overflow Remote Code Execution Vulnerability

    GStreamer FLAC File Parsing Integer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of FLAC audio files. The issue results from the lack of proper validation of user-supplied data, which can result in an integer overflow before allocating a buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-20775

  4. CVE-2017-5840

    Высокий · CVSS 7.5EPSS 4,72%Есть исправление

    CVE-2017-5840

    The qtdemux_parse_samples function in gst/isomp4/qtdemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds heap read) via vectors involving the current stts index.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.3
    Опубликовано Обновлено
  5. CVE-2016-10199

    Высокий · CVSS 7.5EPSS 4,77%Есть исправление

    CVE-2016-10199

    The qtdemux_tag_add_str_full function in gst/isomp4/qtdemux.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted tag value.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.3
    Опубликовано Обновлено
  6. CVE-2016-10198

    Средний · CVSS 5.5EPSS 2,67%Есть исправление

    CVE-2016-10198

    The gst_aac_parse_sink_setcaps function in gst/audioparsers/gstaacparse.c in gst-plugins-good in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via a crafted audio file.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.3
    Опубликовано Обновлено
  7. CVE-2016-9636

    Критический · CVSS 9.8EPSS 8,33%Есть исправление

    CVE-2016-9636

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'write count' that goes beyond the initialized buffer.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.1
    Опубликовано Обновлено
  8. CVE-2016-9635

    Критический · CVSS 9.8EPSS 8,84%Есть исправление

    CVE-2016-9635

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) by providing a 'skip count' that goes beyond initialized buffer.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.1
    Опубликовано Обновлено
  9. CVE-2016-9634

    Критический · CVSS 9.8EPSS 8,84%Есть исправление

    CVE-2016-9634

    Heap-based buffer overflow in the flx_decode_delta_fli function in gst/flx/gstflxdec.c in the FLIC decoder in GStreamer before 1.10.2 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via the start_line parameter.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.1
    Опубликовано Обновлено
  10. CVE-2016-9810

    Средний · CVSS 5.5EPSS 2,37%Есть исправление

    CVE-2016-9810

    The gst_decode_chain_free_internal function in the flxdex decoder in gst-plugins-good in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via an invalid file, which triggers an incorrect unref call.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.2
    Опубликовано Обновлено
  11. CVE-2016-9808

    Высокий · CVSS 7.5EPSS 5,06%Есть исправление

    CVE-2016-9808

    The FLIC decoder in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (out-of-bounds write and crash) via a crafted series of skip and count pairs.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.2
    Опубликовано Обновлено
  12. CVE-2016-9807

    Средний · CVSS 5.5EPSS 2,52%Есть исправление

    CVE-2016-9807

    The flx_decode_chunks function in gst/flx/gstflxdec.c in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (invalid memory read and crash) via a crafted FLIC file.

    • Обновитесь до 0.10.31-3+nmu4ubuntu2.16.04.2
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →