p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости apache2 · Страница 3

За последние 30 дней в apache2 опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 53

  1. CVE-2019-0211

    Высокий · CVSS 7.8EPSS 65%В каталоге KEVПубличный эксплойтЕсть исправление

    CVE-2019-0211

    In Apache HTTP Server 2.4 releases 2.4.17 to 2.4.38, with MPM event, worker or prefork, code executing in less-privileged child processes or threads (including scripts executed by an in-process scripting interpreter) could execute arbitrary code with the privileges of the parent process (usually root) by manipulating the scoreboard. Non-Unix systems are not affected.

    • Обновитесь до 2.4.29-1ubuntu4.6
    Опубликовано Обновлено
  2. CVE-2019-0217

    Высокий · CVSS 7.5EPSS 17,43%Есть исправление

    CVE-2019-0217

    In Apache HTTP Server 2.4 release 2.4.38 and prior, a race condition in mod_auth_digest when running in a threaded server could allow a user with valid credentials to authenticate using another username, bypassing configured access control restrictions.

    • Обновитесь до 2.4.29-1ubuntu4.6
    Опубликовано Обновлено
  3. CVE-2018-17199

    Высокий · CVSS 7.5EPSS 20,16%Есть исправление

    CVE-2018-17199

    In Apache HTTP Server 2.4 release 2.4.37 and prior, mod_session checks the session expiry time before decoding the session. This causes session expiry time to be ignored for mod_session_cookie sessions since the expiry time is loaded when the session is decoded.

    • Обновитесь до 2.4.29-1ubuntu4.6
    Опубликовано Обновлено
  4. CVE-2018-17189

    Средний · CVSS 5.3EPSS 20,07%Есть исправление

    CVE-2018-17189

    In Apache HTTP server versions 2.4.37 and prior, by sending request bodies in a slow loris way to plain resources, the h2 stream for that request unnecessarily occupied a server thread cleaning up that incoming data. This affects only HTTP/2 (mod_http2) connections.

    • Обновитесь до 2.4.29-1ubuntu4.6
    Опубликовано Обновлено
  5. CVE-2018-11763

    Средний · CVSS 5.9EPSS 50,85%Есть исправление

    CVE-2018-11763

    In Apache HTTP Server 2.4.17 to 2.4.34, by sending continuous, large SETTINGS frames a client can occupy a connection, server thread and CPU time without any connection timeout coming to effect. This affects only HTTP/2 connections. A possible mitigation is to not enable the h2 protocol.

    • Обновитесь до 2.4.29-1ubuntu4.4
    Опубликовано Обновлено
  6. CVE-2018-1333

    Высокий · CVSS 7.5EPSS 16,52%Есть исправление

    DoS for HTTP/2 connections by crafted requests

    By specially crafting HTTP/2 requests, workers would be allocated 60 seconds longer than necessary, leading to worker exhaustion and a denial of service. Fixed in Apache HTTP Server 2.4.34 (Affected 2.4.18-2.4.30,2.4.33).

    • Обновитесь до 2.4.29-1ubuntu4.4
    Опубликовано Обновлено
  7. CVE-2018-1312

    Критический · CVSS 9.8EPSS 15,72%Есть исправление

    CVE-2018-1312

    In Apache httpd 2.2.0 to 2.4.29, when generating an HTTP Digest authentication challenge, the nonce sent to prevent reply attacks was not correctly generated using a pseudo-random seed. In a cluster of servers using a common Digest authentication configuration, HTTP requests could be replayed across servers by an attacker without detection.

    • Обновитесь до 2.4.29-1ubuntu4.1
    Опубликовано Обновлено
  8. CVE-2018-1303

    Высокий · CVSS 7.5EPSS 69,8%Есть исправление

    CVE-2018-1303

    A specially crafted HTTP request header could have crashed the Apache HTTP Server prior to version 2.4.30 due to an out of bound read while preparing data to be cached in shared memory. It could be used as a Denial of Service attack against users of mod_cache_socache. The vulnerability is considered as low risk since mod_cache_socache is not widely used, mod_cache_disk is not concerned by this vulnerability.

    • Обновитесь до 2.4.29-1ubuntu4.1
    Опубликовано Обновлено
  9. CVE-2018-1302

    Средний · CVSS 5.9EPSS 12,88%Есть исправление

    CVE-2018-1302

    When an HTTP/2 stream was destroyed after being handled, the Apache HTTP Server prior to version 2.4.30 could have written a NULL pointer potentially to an already freed memory. The memory pools maintained by the server make this vulnerability hard to trigger in usual configurations, the reporter and the team could not reproduce it outside debug builds, so it is classified as low risk.

    • Обновитесь до 2.4.29-1ubuntu4.4
    Опубликовано Обновлено
  10. CVE-2018-1301

    Средний · CVSS 5.9EPSS 14,99%Есть исправление

    CVE-2018-1301

    A specially crafted request could have crashed the Apache HTTP Server prior to version 2.4.30, due to an out of bound access after a size limit is reached by reading the HTTP header. This vulnerability is considered very hard if not impossible to trigger in non-debug mode (both log and build level), so it is classified as low risk for common server usage.

    • Обновитесь до 2.4.29-1ubuntu4.1
    Опубликовано Обновлено
  11. CVE-2018-1283

    Средний · CVSS 5.3EPSS 9,74%Есть исправление

    CVE-2018-1283

    In Apache httpd 2.4.0 to 2.4.29, when mod_session is configured to forward its session data to CGI applications (SessionEnv on, not the default), a remote user may influence their content by using a "Session" header. This comes from the "HTTP_SESSION" variable name used by mod_session to forward its data to CGIs, since the prefix "HTTP_" is also used by the Apache HTTP Server to pass HTTP header fields, per CGI specifications.

    • Обновитесь до 2.4.29-1ubuntu4.1
    Опубликовано Обновлено
  12. CVE-2017-15715

    Высокий · CVSS 8.1EPSS 85,45%Публичный эксплойтЕсть исправление

    CVE-2017-15715

    In Apache httpd 2.4.0 to 2.4.29, the expression specified in <FilesMatch> could match '$' to a newline character in a malicious filename, rather than matching only the end of the filename. This could be exploited in environments where uploads of some files are are externally blocked, but only by matching the trailing portion of the filename.

    • Обновитесь до 2.4.29-1ubuntu4.1
    Опубликовано Обновлено
  13. CVE-2017-15710

    Высокий · CVSS 7.5EPSS 17,08%Есть исправление

    CVE-2017-15710

    In Apache httpd 2.0.23 to 2.0.65, 2.2.0 to 2.2.34, and 2.4.0 to 2.4.29, mod_authnz_ldap, if configured with AuthLDAPCharsetConfig, uses the Accept-Language header value to lookup the right charset encoding when verifying the user's credentials. If the header value is not present in the charset conversion table, a fallback mechanism is used to truncate it to a two characters value to allow a quick retry (for example, 'en-US' is truncated to 'en'). A header value of less than two characters forces an out of bound write of one NUL byte to a memory location that is not part of the string. In the worst case, quite unlikely, the process would crash

    • Обновитесь до 2.4.29-1ubuntu4.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →