p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости jruby · Страница 3

За последние 30 дней в jruby опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 48

  1. CVE-2018-1000076

    Критический · CVSS 9.8EPSS 2,93%Нет опубликованного исправления

    CVE-2018-1000076

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

    Опубликовано Обновлено
  2. CVE-2018-1000075

    Высокий · CVSS 7.5EPSS 4,74%Нет опубликованного исправления

    CVE-2018-1000075

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    Опубликовано Обновлено
  3. CVE-2018-1000074

    Высокий · CVSS 7.8EPSS 2,88%Нет опубликованного исправления

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    Опубликовано Обновлено
  4. CVE-2018-1000073

    Высокий · CVSS 7.5EPSS 4,91%Нет опубликованного исправления

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    Опубликовано Обновлено
  5. CVE-2017-0902

    Высокий · CVSS 8.1EPSS 4,75%Нет опубликованного исправления

    CVE-2017-0902

    RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

    Опубликовано Обновлено
  6. CVE-2017-0901

    Высокий · CVSS 7.5EPSS 29,44%Публичный эксплойтНет опубликованного исправления

    CVE-2017-0901

    RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

    Опубликовано Обновлено
  7. CVE-2017-0900

    Высокий · CVSS 7.5EPSS 8,49%Нет опубликованного исправления

    CVE-2017-0900

    RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.

    Опубликовано Обновлено
  8. CVE-2017-0899

    Критический · CVSS 9.8EPSS 11,1%Нет опубликованного исправления

    CVE-2017-0899

    RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →