p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости qemu · Страница 4

За последние 30 дней в qemu опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 75

  1. CVE-2020-10761

    Средний · CVSS 5EPSS 1,8%Есть исправление

    CVE-2020-10761

    An assertion failure issue was found in the Network Block Device(NBD) Server in all QEMU versions before QEMU 5.0.1. This flaw occurs when an nbd-client sends a spec-compliant request that is near the boundary of maximum permitted request length. A remote nbd-client could use this flaw to crash the qemu-nbd server resulting in a denial of service.

    • Обновитесь до 1:4.2-3ubuntu6.4
  2. CVE-2020-10702

    Средний · CVSS 5.5EPSS 0,33%Есть исправление

    CVE-2020-10702

    A flaw was found in QEMU in the implementation of the Pointer Authentication (PAuth) support for ARM introduced in version 4.0 and fixed in version 5.0.0. A general failure of the signature generation process caused every PAuth-enforced pointer to be signed with the same signature. A local attacker could obtain the signature of a protected pointer and abuse this flaw to bypass PAuth protection for all programs running on QEMU.

    • Обновитесь до 1:4.2-3ubuntu5
  3. CVE-2020-13800

    Средний · CVSS 6EPSS 0,49%Есть исправление

    CVE-2020-13800

    ati-vga in hw/display/ati.c in QEMU 4.2.0 allows guest OS users to trigger infinite recursion via a crafted mm_index value during an ati_mm_read or ati_mm_write call.

    • Обновитесь до 1:4.2-3ubuntu6.4
  4. CVE-2020-13754

    Средний · CVSS 6.7EPSS 0,42%Есть исправление

    CVE-2020-13754

    hw/pci/msix.c in QEMU 4.2.0 allows guest OS users to trigger an out-of-bounds access via a crafted address in an msi-x mmio operation.

    • Обновитесь до 1:4.2-3ubuntu6.4
  5. CVE-2020-13362

    Низкий · CVSS 3.2EPSS 0,38%Есть исправление

    CVE-2020-13362

    In QEMU 5.0.0 and earlier, megasas_lookup_frame in hw/scsi/megasas.c has an out-of-bounds read via a crafted reply_queue_head field from a guest OS user.

    • Обновитесь до 1:4.2-3ubuntu6.4
  6. CVE-2020-13361

    Низкий · CVSS 3.9EPSS 0,37%Есть исправление

    CVE-2020-13361

    In QEMU 5.0.0 and earlier, es1370_transfer_audio in hw/audio/es1370.c does not properly validate the frame count, which allows guest OS users to trigger an out-of-bounds access during an es1370_write() operation.

    • Обновитесь до 1:4.2-3ubuntu6.4
  7. CVE-2020-13253

    Средний · CVSS 5.5EPSS 0,43%Есть исправление

    CVE-2020-13253

    sd_wp_addr in hw/sd/sd.c in QEMU 4.2.0 uses an unvalidated address, which leads to an out-of-bounds read during sdhci_write() operations. A guest OS user can crash the QEMU process.

    • Обновитесь до 1:4.2-3ubuntu6.4
  8. CVE-2020-11869

    Низкий · CVSS 3.3EPSS 0,4%Есть исправление

    CVE-2020-11869

    An integer overflow was found in QEMU 4.0.1 through 4.2.0 in the way it implemented ATI VGA emulation. This flaw occurs in the ati_2d_blt() routine in hw/display/ati-2d.c while handling MMIO write operations through the ati_mm_write() callback. A malicious guest could abuse this flaw to crash the QEMU process, resulting in a denial of service.

    • Обновитесь до 1:4.2-3ubuntu6.1
    Опубликовано Обновлено
  9. CVE-2020-1711

    Высокий · CVSS 7.7EPSS 4,02%Есть исправление

    CVE-2020-1711

    An out-of-bounds heap buffer access flaw was found in the way the iSCSI Block driver in QEMU versions 2.12.0 before 4.2.1 handled a response coming from an iSCSI server while checking the status of a Logical Address Block (LBA) in an iscsi_co_block_status() routine. A remote user could use this flaw to crash the QEMU process, resulting in a denial of service or potential execution of arbitrary code with privileges of the QEMU process on the host.

    • Обновитесь до 1:4.2-3ubuntu1
    Опубликовано Обновлено
  10. CVE-2019-12068

    Низкий · CVSS 3.8EPSS 0,51%Есть исправление

    CVE-2019-12068

    In QEMU 1:4.1-1, 1:2.1+dfsg-12+deb8u6, 1:2.8+dfsg-6+deb9u8, 1:3.1+dfsg-8~deb10u1, 1:3.1+dfsg-8+deb10u2, and 1:2.1+dfsg-12+deb8u12 (fixed), when executing script in lsi_execute_script(), the LSI scsi adapter emulator advances 's->dsp' index to read next opcode. This can lead to an infinite loop if the next opcode is empty. Move the existing loop exit after 10k iterations so that it covers no-op opcodes as well.

    • Обновитесь до 1:4.2-1ubuntu1
    Опубликовано Обновлено
  11. CVE-2019-14378

    Высокий · CVSS 8.8EPSS 16,66%Публичный эксплойтЕсть исправление

    CVE-2019-14378

    ip_reass in ip_input.c in libslirp 4.0.0 has a heap-based buffer overflow via a large packet because it mishandles a case involving the first fragment.

    • Обновитесь до 1:4.2-1ubuntu1

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →