p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости jruby · Страница 2

За последние 30 дней в jruby опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 36

  1. CVE-2024-41123

    Средний · CVSS 5.3EPSS 1,28%Нет опубликованного исправления

    REXML DoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.2 has some DoS vulnerabilities when it parses an XML that has many specific characters such as whitespace character, `>]` and `]>`. The REXML gem 3.3.3 or later include the patches to fix these vulnerabilities.

    Опубликовано Обновлено
  2. CVE-2024-39908

    Средний · CVSS 4.3EPSS 1,49%Нет опубликованного исправления

    Denial of service in REXML

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.

  3. CVE-2024-35176

    Средний · CVSS 5.3EPSS 2,06%Нет опубликованного исправления

    REXML contains a denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many `<`s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this vulnerability. As a workaround, don't parse untrusted XMLs.

  4. CVE-2024-27281

    Средний · CVSS 4.5EPSS 1,57%Нет опубликованного исправления

    CVE-2024-27281

    An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.

  5. CVE-2024-27282

    Средний · CVSS 6.6EPSS 0,66%Нет опубликованного исправления

    CVE-2024-27282

    An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

  6. CVE-2023-36617

    Средний · CVSS 5.3EPSS 1,7%Нет опубликованного исправления

    CVE-2023-36617

    A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with rfc2396_parser.rb and rfc3986_parser.rb. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version.

  7. CVE-2023-28756

    Средний · CVSS 5.3EPSS 2,45%Нет опубликованного исправления

    CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

  8. CVE-2023-28755

    Средний · CVSS 5.3EPSS 2,64%Нет опубликованного исправления

    CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

  9. CVE-2021-33621

    Высокий · CVSS 8.8EPSS 2,45%Нет опубликованного исправления

    CVE-2021-33621

    The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

    Опубликовано Обновлено
  10. CVE-2019-16255

    Высокий · CVSS 8.1EPSS 4,19%Нет опубликованного исправления

    CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    Опубликовано Обновлено
  11. CVE-2019-16201

    Высокий · CVSS 7.5EPSS 5,09%Нет опубликованного исправления

    CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    Опубликовано Обновлено
  12. CVE-2017-17742

    Средний · CVSS 5.3EPSS 5,45%Нет опубликованного исправления

    CVE-2017-17742

    Ruby before 2.2.10, 2.3.x before 2.3.7, 2.4.x before 2.4.4, 2.5.x before 2.5.1, and 2.6.0-preview1 allows an HTTP Response Splitting attack. An attacker can inject a crafted key and value into an HTTP response for the HTTP server of WEBrick.

    Опубликовано Обновлено
  13. CVE-2017-0902

    Высокий · CVSS 8.1EPSS 4,75%Нет опубликованного исправления

    CVE-2017-0902

    RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

    Опубликовано Обновлено
  14. CVE-2017-0901

    Высокий · CVSS 7.5EPSS 29,44%Публичный эксплойтНет опубликованного исправления

    CVE-2017-0901

    RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

    Опубликовано Обновлено
  15. CVE-2017-0900

    Высокий · CVSS 7.5EPSS 8,49%Нет опубликованного исправления

    CVE-2017-0900

    RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.

    Опубликовано Обновлено
  16. CVE-2017-0899

    Критический · CVSS 9.8EPSS 11,1%Нет опубликованного исправления

    CVE-2017-0899

    RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →