p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости jruby · Страница 3

За последние 30 дней в jruby опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 50

  1. CVE-2018-1000075

    Высокий · CVSS 7.5EPSS 4,74%Есть исправление

    CVE-2018-1000075

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a infinite loop caused by negative size vulnerability in ruby gem package tar header that can result in a negative size could cause an infinite loop.. This vulnerability appears to have been fixed in 2.7.6.

    • Обновитесь до 1.5.6-9+deb8u2build0.14.04.1~esm2
    Опубликовано Обновлено
  2. CVE-2018-1000074

    Высокий · CVSS 7.8EPSS 2,88%Есть исправление

    CVE-2018-1000074

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

    • Обновитесь до 1.5.6-9+deb8u2build0.14.04.1~esm2
    Опубликовано Обновлено
  3. CVE-2018-1000073

    Высокий · CVSS 7.5EPSS 4,91%Нет опубликованного исправления

    CVE-2018-1000073

    RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in install_location function of package.rb that can result in path traversal when writing to a symlinked basedir outside of the root. This vulnerability appears to have been fixed in 2.7.6.

    Опубликовано Обновлено
  4. CVE-2017-0903

    Критический · CVSS 9.8EPSS 15,85%Нет опубликованного исправления

    CVE-2017-0903

    RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution.

    Опубликовано Обновлено
  5. CVE-2017-0902

    Высокий · CVSS 8.1EPSS 4,75%Нет опубликованного исправления

    CVE-2017-0902

    RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.

    Опубликовано Обновлено
  6. CVE-2017-0901

    Высокий · CVSS 7.5EPSS 29,44%Публичный эксплойтНет опубликованного исправления

    CVE-2017-0901

    RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

    Опубликовано Обновлено
  7. CVE-2017-0900

    Высокий · CVSS 7.5EPSS 8,49%Нет опубликованного исправления

    CVE-2017-0900

    RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.

    Опубликовано Обновлено
  8. CVE-2017-0899

    Критический · CVSS 9.8EPSS 11,1%Нет опубликованного исправления

    CVE-2017-0899

    RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

    Опубликовано Обновлено
  9. CVE-2012-2126

    Без оценкиEPSS 1,36%Нет опубликованного исправления

    CVE-2012-2126

    RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.

    Опубликовано Обновлено
  10. CVE-2012-2125

    Без оценкиEPSS 2,47%Нет опубликованного исправления

    CVE-2012-2125

    RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →