p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости bind9 · Страница 2

За последние 30 дней в bind9 опубликовано уязвимостей: 3; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 34

  1. CVE-2024-1975

    Высокий · CVSS 7.5EPSS 2,11%Есть исправление

    SIG(0) can be used to exhaust CPU resources

    If a server hosts a zone containing a "KEY" Resource Record, or a resolver DNSSEC-validates a "KEY" Resource Record from a DNSSEC-signed domain in cache, a client can exhaust resolver CPU resources by sending a stream of SIG(0) signed requests. This issue affects BIND 9 versions 9.0.0 through 9.11.37, 9.16.0 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.9.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.49-S1, and 9.18.11-S1 through 9.18.27-S1.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm9
    Опубликовано Обновлено
  2. CVE-2024-1737

    Высокий · CVSS 7.5EPSS 2,11%Есть исправление

    BIND's database will be slow if a very large number of RRs exist at the same name

    Resolver caches and authoritative zone databases that hold significant numbers of RRs for the same hostname (of any RTYPE) can suffer from degraded performance as content is being added or updated, and also when handling client queries for this name. This issue affects BIND 9 versions 9.11.0 through 9.11.37, 9.16.0 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.11.4-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.50-S1, and 9.18.11-S1 through 9.18.27-S1.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm9
    Опубликовано Обновлено
  3. CVE-2023-50868

    Высокий · CVSS 7.5EPSS 74,3%Есть исправление

    CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm8
    Опубликовано Обновлено
  4. CVE-2023-50387

    Высокий · CVSS 7.5EPSS 99,99%Есть исправление

    CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm8
    Опубликовано Обновлено
  5. CVE-2023-4408

    Высокий · CVSS 7.5EPSS 1,39%Нет опубликованного исправления

    Parsing large DNS messages may cause excessive CPU load

    The DNS message parsing code in `named` includes a section whose computational complexity is overly high. It does not cause problems for typical DNS traffic, but crafted queries and responses may cause excessive CPU load on the affected `named` instance by exploiting this flaw. This issue affects both authoritative servers and recursive resolvers. This issue affects BIND 9 versions 9.0.0 through 9.16.45, 9.18.0 through 9.18.21, 9.19.0 through 9.19.19, 9.9.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.45-S1, and 9.18.11-S1 through 9.18.21-S1.

    Опубликовано Обновлено
  6. CVE-2023-3341

    Высокий · CVSS 7.5EPSS 2,93%Есть исправление

    A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly

    The code that processes control channel messages sent to `named` calls certain functions recursively during packet parsing. Recursion depth is only limited by the maximum accepted packet size; depending on the environment, this may cause the packet-parsing code to run out of available stack memory, causing `named` to terminate unexpectedly. Since each incoming control channel message is fully parsed before its contents are authenticated, exploiting this flaw does not require the attacker to hold a valid RNDC key; only network access to the control channel's configured TCP port is necessary. This issue affects BIND 9 versions 9.2.0 through 9.1

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm7
    Опубликовано Обновлено
  7. CVE-2023-2828

    Высокий · CVSS 7.5EPSS 3,7%Есть исправление

    named's configured cache size limit can be significantly exceeded

    Every `named` instance configured to run as a recursive resolver maintains a cache database holding the responses to the queries it has recently sent to authoritative servers. The size limit for that cache database can be configured using the `max-cache-size` statement in the configuration file; it defaults to 90% of the total amount of memory available on the host. When the size of the cache reaches 7/8 of the configured limit, a cache-cleaning algorithm starts to remove expired and/or least-recently used RRsets from the cache, to keep memory use below the configured limit. It has been discovered that the effectiveness of the cache-cleaning

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm6
    Опубликовано Обновлено
  8. CVE-2022-38177

    Высокий · CVSS 7.5EPSS 3,29%Есть исправление

    Memory leak in ECDSA DNSSEC verification code

    By spoofing the target resolver with responses that have a malformed ECDSA signature, an attacker can trigger a small memory leak. It is possible to gradually erode available memory to the point where named crashes for lack of resources.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm3
    Опубликовано Обновлено
  9. CVE-2022-2795

    Средний · CVSS 5.3EPSS 2,29%Есть исправление

    Processing large delegations may severely degrade resolver performance

    By flooding the target resolver with queries exploiting this flaw an attacker can significantly impair the resolver's performance, effectively denying legitimate clients access to the DNS resolution service.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm3
    Опубликовано Обновлено
  10. CVE-2021-25220

    Средний · CVSS 6.8EPSS 3,45%Есть исправление

    DNS forwarders - cache poisoning vulnerability

    BIND 9.11.0 -> 9.11.36 9.12.0 -> 9.16.26 9.17.0 -> 9.18.0 BIND Supported Preview Editions: 9.11.4-S1 -> 9.11.36-S1 9.16.8-S1 -> 9.16.26-S1 Versions of BIND 9 earlier than those shown - back to 9.1.0, including Supported Preview Editions - are also believed to be affected but have not been tested as they are EOL. The cache could become poisoned with incorrect records leading to queries being made to the wrong servers, which might also result in false information being returned to clients.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm2
    Опубликовано Обновлено
  11. CVE-2021-25219

    Средний · CVSS 5.3EPSS 11,16%Есть исправление

    Lame cache can be abused to severely degrade resolver performance

    In BIND 9.3.0 -> 9.11.35, 9.12.0 -> 9.16.21, and versions 9.9.3-S1 -> 9.11.35-S1 and 9.16.8-S1 -> 9.16.21-S1 of BIND Supported Preview Edition, as well as release versions 9.17.0 -> 9.17.18 of the BIND 9.17 development branch, exploitation of broken authoritative servers using a flaw in response processing can cause degradation in BIND resolver performance. The way the lame cache is currently designed makes it possible for its internal data structures to grow almost infinitely, which may cause significant delays in client query processing.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm1
    Опубликовано Обновлено
  12. CVE-2018-5741

    Средний · CVSS 6.5EPSS 3,45%Нет опубликованного исправления

    Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation

    To provide fine-grained controls over the ability to use Dynamic DNS (DDNS) to update records in a zone, BIND 9 provides a feature called update-policy. Various rules can be configured to limit the types of updates that can be performed by a client, depending on the key used when sending the update request. Unfortunately, some rule types were not initially documented, and when documentation for them was added to the Administrator Reference Manual (ARM) in change #3112, the language that was added to the ARM at that time incorrectly described the behavior of two rule types, krb5-subdomain and ms-subdomain. This incorrect documentation could mi

    Опубликовано Обновлено
  13. CVE-2016-2775

    Средний · CVSS 5.9EPSS 63,35%Есть исправление

    CVE-2016-2775

    ISC BIND 9.x before 9.9.9-P2, 9.10.x before 9.10.4-P2, and 9.11.x before 9.11.0b2, when lwresd or the named lwres option is enabled, allows remote attackers to cause a denial of service (daemon crash) via a long request that uses the lightweight resolver protocol.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm5
  14. CVE-2016-6170

    Средний · CVSS 6.5EPSS 40,94%Есть исправление

    CVE-2016-6170

    ISC BIND through 9.9.9-P1, 9.10.x through 9.10.4-P1, and 9.11.x through 9.11.0b1 allows primary DNS servers to cause a denial of service (secondary DNS server crash) via a large AXFR response, and possibly allows IXFR servers to cause a denial of service (IXFR client crash) via a large IXFR response and allows remote authenticated users to cause a denial of service (primary DNS server crash) via a large UPDATE message.

    • Обновитесь до 1:9.10.3.dfsg.P4-8ubuntu1.19+esm5

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →