p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости ruby2.5 · Страница 2

За последние 30 дней в ruby2.5 опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 31

  1. CVE-2024-49761

    Средний · CVSS 6.6EPSS 1,42%Есть исправление

    REXML ReDoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.9 has a ReDoS vulnerability when it parses an XML that has many digits between &# and x...; in a hex numeric character reference (&#x...;). This does not happen with Ruby 3.2 or later. Ruby 3.1 is the only affected maintained Ruby. The REXML gem 3.3.9 or later include the patch to fix the vulnerability.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm4
    Опубликовано Обновлено
  2. CVE-2024-47220

    Без оценкиЕсть исправление

    UBUNTU-CVE-2024-47220

    Rejected reason: DO NOT USE THIS CVE RECORD. ConsultIDs: none. Reason: This record was withdrawn by its CNA. Further investigation showed that it was not a security issue. Notes: none.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm6
    Опубликовано Обновлено
  3. CVE-2024-43398

    Средний · CVSS 5.9EPSS 1,21%Нет опубликованного исправления

    REXML denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.6 has a DoS vulnerability when it parses an XML that has many deep elements that have same local name attributes. If you need to parse untrusted XMLs with tree parser API like REXML::Document.new, you may be impacted to this vulnerability. If you use other parser APIs such as stream parser API and SAX2 parser API, this vulnerability is not affected. The REXML gem 3.3.6 or later include the patch to fix the vulnerability.

    Опубликовано Обновлено
  4. CVE-2024-41946

    Средний · CVSS 5.3EPSS 1,19%Есть исправление

    REXML DoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem 3.3.2 has a DoS vulnerability when it parses an XML that has many entity expansions with SAX2 or pull parser API. The REXML gem 3.3.3 or later include the patch to fix the vulnerability.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm6
    Опубликовано Обновлено
  5. CVE-2024-41123

    Средний · CVSS 5.3EPSS 1,28%Есть исправление

    REXML DoS vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.2 has some DoS vulnerabilities when it parses an XML that has many specific characters such as whitespace character, `>]` and `]>`. The REXML gem 3.3.3 or later include the patches to fix these vulnerabilities.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm6
    Опубликовано Обновлено
  6. CVE-2024-39908

    Средний · CVSS 4.3EPSS 1,49%Есть исправление

    Denial of service in REXML

    REXML is an XML toolkit for Ruby. The REXML gem before 3.3.1 has some DoS vulnerabilities when it parses an XML that has many specific characters such as `<`, `0` and `%>`. If you need to parse untrusted XMLs, you many be impacted to these vulnerabilities. The REXML gem 3.3.2 or later include the patches to fix these vulnerabilities. Users are advised to upgrade. Users unable to upgrade should avoid parsing untrusted XML strings.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm6
  7. CVE-2024-35176

    Средний · CVSS 5.3EPSS 2,06%Есть исправление

    REXML contains a denial of service vulnerability

    REXML is an XML toolkit for Ruby. The REXML gem before 3.2.6 has a denial of service vulnerability when it parses an XML that has many `<`s in an attribute value. Those who need to parse untrusted XMLs may be impacted to this vulnerability. The REXML gem 3.2.7 or later include the patch to fix this vulnerability. As a workaround, don't parse untrusted XMLs.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm5
  8. CVE-2024-27281

    Средний · CVSS 4.5EPSS 1,57%Есть исправление

    CVE-2024-27281

    An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm3
  9. CVE-2024-27280

    Критический · CVSS 9.8EPSS 2,36%Есть исправление

    CVE-2024-27280

    A buffer-overread issue was discovered in StringIO 3.0.1, as distributed in Ruby 3.0.x through 3.0.6 and 3.1.x through 3.1.4. The ungetbyte and ungetc methods on a StringIO can read past the end of a string, and a subsequent call to StringIO.gets may return the memory value. 3.0.3 is the main fixed version; however, for Ruby 3.0 users, a fixed version is stringio 3.0.1.1, and for Ruby 3.1 users, a fixed version is stringio 3.0.1.2.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm5
  10. CVE-2024-27282

    Средний · CVSS 6.6EPSS 0,66%Есть исправление

    CVE-2024-27282

    An issue was discovered in Ruby 3.x through 3.3.0. If attacker-supplied data is provided to the Ruby regex compiler, it is possible to extract arbitrary heap data relative to the start of the text, including pointers and sensitive strings. The fixed versions are 3.0.7, 3.1.5, 3.2.4, and 3.3.1.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm5
  11. CVE-2023-36617

    Средний · CVSS 5.3EPSS 1,7%Есть исправление

    CVE-2023-36617

    A ReDoS issue was discovered in the URI component before 0.12.2 for Ruby. The URI parser mishandles invalid URLs that have specific characters. There is an increase in execution time for parsing strings to URI objects with rfc2396_parser.rb and rfc3986_parser.rb. NOTE: this issue exists becuse of an incomplete fix for CVE-2023-28755. Version 0.10.3 is also a fixed version.

    • Обновитесь до 2.5.1-1ubuntu1.16+esm1

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →