p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости cups · Страница 2

За последние 30 дней в cups опубликовано уязвимостей: 9; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 23

  1. CVE-2025-61915

    Средний · CVSS 6EPSS 0,46%Есть исправление

    OpenPrinting CUPS vulnerable to stack based out-of-bound write

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

    • Обновитесь до 2.3.1-9ubuntu1.9+esm3
    Опубликовано Обновлено
  2. CVE-2025-58364

    Средний · CVSS 6.5EPSS 1,16%Есть исправление

    cups: Remote DoS via null dereference

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, an unsafe deserialization and validation of printer attributes causes null dereference in the libcups library. This is a remote DoS vulnerability available in local subnet in default configurations. It can cause the cups & cups-browsed to crash, on all the machines in local network who are listening for printers (so by default for all regular linux machines). On systems where the vulnerability CVE-2024-47176 (cups-filters 1.x/cups-browsed 2.x vulnerability) was not fixed, and the firewall on the machine does not

    • Обновитесь до 2.3.1-9ubuntu1.9+esm1
    Опубликовано Обновлено
  3. CVE-2025-58060

    Высокий · CVSS 8EPSS 1%Есть исправление

    cups has Authentication bypass with AuthType Negotiate

    OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the `AuthType` is set to anything but `Basic`, if the request contains an `Authorization: Basic ...` header, the password is not checked. This results in authentication bypass. Any configuration that allows an `AuthType` that is not `Basic` is affected. Version 2.4.13 fixes the issue.

    • Обновитесь до 2.3.1-9ubuntu1.9+esm1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →