p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости bind

За последние 30 дней в bind опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 73

  1. ALPINE-CVE-2026-5950

    Средний · CVSS 5.3Есть исправление

    ALPINE-CVE-2026-5950

    An unbounded resend loop vulnerability exists in the BIND 9 resolver state machine during bad-server handling, enabling a remote unauthenticated attacker to cause severe resource exhaustion by sending queries that trigger specific retry conditions. This issue affects BIND 9 versions 9.18.36 through 9.18.48, 9.20.8 through 9.20.22, 9.21.7 through 9.21.21, 9.18.36-S1 through 9.18.48-S1, and 9.20.9-S1 through 9.20.22-S1.

    • Обновитесь до 9.18.49-r0
    Опубликовано Обновлено
  2. ALPINE-CVE-2026-5947

    Средний · CVSS 5.9Есть исправление

    ALPINE-CVE-2026-5947

    Undefined behavior may result due to a race condition leading to a use-after-free violation. If BIND receives an incoming DNS message signed with SIG(0), it begins work to validate that signature. If, during that validation, the "recursive-clients" limit is reached (as would occur during a query flood), and that same DNS message is discarded per the limit, there is a brief window of time while the SIG(0) validation may attempt to read the now-discarded DNS message. This issue affects BIND 9 versions 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, and 9.20.9-S1 through 9.20.22-S1. BIND 9 versions 9.18.28 through 9.18.49 and 9.18.28-S1 throug

    • Обновитесь до 9.18.49-r0
    Опубликовано Обновлено
  3. ALPINE-CVE-2026-5946

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2026-5946

    Multiple flaws have been identified in `named` related to the handling of DNS messages whose CLASS is not Internet (`IN`) — for example, `CHAOS` or `HESIOD`, or DNS messages that specify meta-classes (`ANY` or `NONE`) in the question section. Specially crafted requests reaching the affected code paths — recursion, dynamic updates (`UPDATE`), zone change notifications (`NOTIFY`), or processing of `IN`-specific record types in non-`IN` data — can cause assertion failures in `named`. This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.48, 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, 9.11.3-S1 through 9.16.50-S1, 9.1

    • Обновитесь до 9.18.49-r0
    Опубликовано Обновлено
  4. ALPINE-CVE-2026-3593

    Критический · CVSS 9.8Есть исправление

    ALPINE-CVE-2026-3593

    A use-after-free vulnerability exists within the DNS-over-HTTPS implementation. This issue affects BIND 9 versions 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, and 9.20.9-S1 through 9.20.22-S1. BIND 9 versions 9.18.0 through 9.18.48 and 9.18.11-S1 through 9.18.48-S1 are NOT affected.

    • Обновитесь до 9.18.49-r0
    Опубликовано Обновлено
  5. ALPINE-CVE-2026-3592

    Средний · CVSS 5.3Есть исправление

    ALPINE-CVE-2026-3592

    BIND resolvers are vulnerable to an amplified resource consumption/exhaustion attack. If a victim resolver makes a query to a specially crafted zone, the resolver will consume disproportionate resources. This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.48, 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, 9.11.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.48-S1, and 9.20.9-S1 through 9.20.22-S1.

    • Обновитесь до 9.18.49-r0
    Опубликовано Обновлено
  6. ALPINE-CVE-2026-3039

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2026-3039

    BIND servers that are configured to use TKEY-based authentication via GSS-API tokens are vulnerable to excessive memory consumption when receiving and processing maliciously-constructed packets. Typically these servers will be found in Active Directory integrated DNS deployments and/or Kerberos-secured DNS environments. This issue affects BIND 9 versions 9.0.0 through 9.16.50, 9.18.0 through 9.18.48, 9.20.0 through 9.20.22, 9.21.0 through 9.21.21, 9.9.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.48-S1, and 9.20.9-S1 through 9.20.22-S1.

    • Обновитесь до 9.18.49-r0
    Опубликовано Обновлено
  7. ALPINE-CVE-2026-1519

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2026-1519

    If a BIND resolver is performing DNSSEC validation and encounters a maliciously crafted zone, the resolver may consume excessive CPU. Authoritative-only servers are generally unaffected, although there are circumstances where authoritative servers may make recursive queries (see: https://kb.isc.org/docs/why-does-my-authoritative-server-make-recursive-queries). This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.46, 9.20.0 through 9.20.20, 9.21.0 through 9.21.19, 9.11.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.46-S1, and 9.20.9-S1 through 9.20.20-S1.

    • Обновитесь до 9.18.47-r0
    Опубликовано Обновлено
  8. ALPINE-CVE-2025-13878

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2025-13878

    Malformed BRID/HHIT records can cause `named` to terminate unexpectedly. This issue affects BIND 9 versions 9.18.40 through 9.18.43, 9.20.13 through 9.20.17, 9.21.12 through 9.21.16, 9.18.40-S1 through 9.18.43-S1, and 9.20.13-S1 through 9.20.17-S1.

    • Обновитесь до 9.18.44-r0
    Опубликовано Обновлено
  9. ALPINE-CVE-2025-8677

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2025-8677

    Querying for records within a specially crafted zone containing certain malformed DNSKEY records can lead to CPU exhaustion. This issue affects BIND 9 versions 9.18.0 through 9.18.39, 9.20.0 through 9.20.13, 9.21.0 through 9.21.12, 9.18.11-S1 through 9.18.39-S1, and 9.20.9-S1 through 9.20.13-S1.

    • Обновитесь до 9.18.41-r0
    Опубликовано Обновлено
  10. ALPINE-CVE-2025-40780

    Высокий · CVSS 8.6Есть исправление

    ALPINE-CVE-2025-40780

    In specific circumstances, due to a weakness in the Pseudo Random Number Generator (PRNG) that is used, it is possible for an attacker to predict the source port and query ID that BIND will use. This issue affects BIND 9 versions 9.16.0 through 9.16.50, 9.18.0 through 9.18.39, 9.20.0 through 9.20.13, 9.21.0 through 9.21.12, 9.16.8-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.39-S1, and 9.20.9-S1 through 9.20.13-S1.

    • Обновитесь до 9.18.41-r0
    Опубликовано Обновлено
  11. ALPINE-CVE-2025-40778

    Высокий · CVSS 8.6Есть исправление

    ALPINE-CVE-2025-40778

    Under certain circumstances, BIND is too lenient when accepting records from answers, allowing an attacker to inject forged data into the cache. This issue affects BIND 9 versions 9.11.0 through 9.16.50, 9.18.0 through 9.18.39, 9.20.0 through 9.20.13, 9.21.0 through 9.21.12, 9.11.3-S1 through 9.16.50-S1, 9.18.11-S1 through 9.18.39-S1, and 9.20.9-S1 through 9.20.13-S1.

    • Обновитесь до 9.18.41-r0
    Опубликовано Обновлено
  12. ALPINE-CVE-2025-40775

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2025-40775

    When an incoming DNS protocol message includes a Transaction Signature (TSIG), BIND always checks it. If the TSIG contains an invalid value in the algorithm field, BIND immediately aborts with an assertion failure. This issue affects BIND 9 versions 9.20.0 through 9.20.8 and 9.21.0 through 9.21.7.

    • Обновитесь до 9.18.37-r0
    Опубликовано Обновлено
  13. ALPINE-CVE-2024-12705

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2024-12705

    Clients using DNS-over-HTTPS (DoH) can exhaust a DNS resolver's CPU and/or memory by flooding it with crafted valid or invalid HTTP/2 traffic. This issue affects BIND 9 versions 9.18.0 through 9.18.32, 9.20.0 through 9.20.4, 9.21.0 through 9.21.3, and 9.18.11-S1 through 9.18.32-S1.

    • Обновитесь до 9.18.33-r0
    Опубликовано Обновлено
  14. ALPINE-CVE-2024-11187

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2024-11187

    It is possible to construct a zone such that some queries to it will generate responses containing numerous records in the Additional section. An attacker sending many such queries can cause either the authoritative server itself or an independent resolver to use disproportionate resources processing the queries. Zones will usually need to have been deliberately crafted to attack this exposure. This issue affects BIND 9 versions 9.11.0 through 9.11.37, 9.16.0 through 9.16.50, 9.18.0 through 9.18.32, 9.20.0 through 9.20.4, 9.21.0 through 9.21.3, 9.11.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.50-S1, and 9.18.11-S1 through 9.18.32-S1.

    • Обновитесь до 9.18.33-r0
    Опубликовано Обновлено
  15. ALPINE-CVE-2024-4076

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2024-4076

    Client queries that trigger serving stale data and that also require lookups in local authoritative zone data may result in an assertion failure. This issue affects BIND 9 versions 9.16.13 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.11.33-S1 through 9.11.37-S1, 9.16.13-S1 through 9.16.50-S1, and 9.18.11-S1 through 9.18.27-S1.

    • Обновитесь до 9.18.28-r0
    Опубликовано Обновлено
  16. ALPINE-CVE-2024-1975

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2024-1975

    If a server hosts a zone containing a "KEY" Resource Record, or a resolver DNSSEC-validates a "KEY" Resource Record from a DNSSEC-signed domain in cache, a client can exhaust resolver CPU resources by sending a stream of SIG(0) signed requests. This issue affects BIND 9 versions 9.0.0 through 9.11.37, 9.16.0 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.9.3-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.49-S1, and 9.18.11-S1 through 9.18.27-S1.

    • Обновитесь до 9.18.28-r0
    Опубликовано Обновлено
  17. ALPINE-CVE-2024-1737

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2024-1737

    Resolver caches and authoritative zone databases that hold significant numbers of RRs for the same hostname (of any RTYPE) can suffer from degraded performance as content is being added or updated, and also when handling client queries for this name. This issue affects BIND 9 versions 9.11.0 through 9.11.37, 9.16.0 through 9.16.50, 9.18.0 through 9.18.27, 9.19.0 through 9.19.24, 9.11.4-S1 through 9.11.37-S1, 9.16.8-S1 through 9.16.50-S1, and 9.18.11-S1 through 9.18.27-S1.

    • Обновитесь до 9.18.28-r0
    Опубликовано Обновлено
  18. ALPINE-CVE-2024-0760

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2024-0760

    A malicious client can send many DNS messages over TCP, potentially causing the server to become unstable while the attack is in progress. The server may recover after the attack ceases. Use of ACLs will not mitigate the attack. This issue affects BIND 9 versions 9.18.1 through 9.18.27, 9.19.0 through 9.19.24, and 9.18.11-S1 through 9.18.27-S1.

    • Обновитесь до 9.18.28-r0
    Опубликовано Обновлено
  19. ALPINE-CVE-2023-50868

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2023-50868

    The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in a random subdomain attack, aka the "NSEC3" issue. The RFC 5155 specification implies that an algorithm must perform thousands of iterations of a hash function in certain situations.

    • Обновитесь до 9.18.24-r0
    Опубликовано Обновлено
  20. ALPINE-CVE-2023-50387

    Высокий · CVSS 7.5Есть исправление

    ALPINE-CVE-2023-50387

    Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG records.

    • Обновитесь до 9.18.24-r0
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →