CVE-2018-1000132
CVE-2018-1000132
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.
CVSS 9.3 · Критический · EPSS 2,6% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
n/a
- Версии
- n/a: Затронуто
Нет опубликованного исправления
mercurial Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.5.2-1
Обновитесь до 4.5.2-1
mercurial Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.5.2-1
Обновитесь до 4.5.2-1
mercurial Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.5.2-1
Обновитесь до 4.5.2-1
mercurial PyPI
- Версии
- 0.8.1
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 1.0
- 1.0.1
- 1.0.2
- 1.1
- 1.1.1
- 1.1.2
- 1.2
- 1.2.1
- 1.3
- 1.3.1
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.5.4
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.7
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.5
- 1.8
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9
- 1.9.1
- 1.9.2
- 1.9.3
- 2.0
- 2.0.1
- 2.0.2
- 2.1
- 2.1.1
- 2.1.2
- 2.2
- 2.2.2
- 2.3
- 2.4.1
- 2.5
- 2.5.1
- 2.5.2
- 2.6
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.1
- 2.7.2
- 2.8
- 2.8.1
- 2.8.2
- 2.9
- 2.9.1
- 3.0
- 3.0.1
- 3.1
- 3.1.1
- 3.1.2
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.3
- 3.3-rc
- 3.3.1
- 3.3.2
- 3.3.3
- 3.4
- 3.4-rc
- 3.4.1
- 3.4.2
- 3.5
- 3.5-rc
- 3.5.1
- 3.5.2
- 3.6
- 3.6-rc
- 3.6.1
- 3.6.2
- 3.6.3
- 3.7
- 3.7-rc
- 3.7.1
- 3.7.2
- 3.7.3
- 3.8
- 3.8-rc
- 3.8.1
- 3.8.2
- 3.8.3
- 3.8.4
- 3.9
- 3.9-rc
- 3.9.1
- 3.9.2
- 4.0
- 4.0-rc
- 4.0.1
- 4.0.2
- 4.1
- 4.1-rc
- 4.1.1
- 4.1.2
- 4.1.3
- 4.2
- 4.2-rc
- 4.2.1
- 4.2.2
- 4.2.3
- 4.3
- 4.3-rc
- 4.3.1
- 4.3.2
- 4.3.3
- 4.3rc0
- 4.4
- 4.4-rc
- 4.4.1
- 4.4.2
- 4.4rc0
- 4.5
- 4.5-rc
- 4.5rc0
- Затронутые диапазоны версий
- ECOSYSTEM: < 4.5.1
Обновитесь до 4.5.1
mercurial Ubuntu:14.04:LTS
- Версии
- 2.6.3-1
- 2.7.2-1
- 2.8.1-2
- 2.8.2-1ubuntu1
- 2.8.2-1ubuntu1.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.8.2-1ubuntu1.4
Обновитесь до 2.8.2-1ubuntu1.4
mercurial Ubuntu:16.04:LTS
- Версии
- 3.4-1ubuntu2
- 3.6.2-1ubuntu2
- 3.7.3-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.7.3-1ubuntu1.1
Обновитесь до 3.7.3-1ubuntu1.1
Первоисточники
- https://lists.debian.org/debian-lts-announce/2018/03/msg00034.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.5.1_.2F_4.5.2_.282018-03-06.29
- https://access.redhat.com/errata/RHSA-2019:2276
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000132