p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости mercurial

За последние 30 дней в mercurial опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 9

  1. CVE-2018-13348

    Высокий · CVSS 8.7EPSS 2,1%Есть исправление

    CVE-2018-13348

    The mpatch_decode function in mpatch.c in Mercurial before 4.6.1 mishandles certain situations where there should be at least 12 bytes remaining after the current position in the patch data, but actually are not, aka OVE-20180430-0001.

    • Обновитесь до 3.7.3-1ubuntu1.1
  2. CVE-2018-13346

    Высокий · CVSS 8.7EPSS 2,36%Есть исправление

    CVE-2018-13346

    The mpatch_apply function in mpatch.c in Mercurial before 4.6.1 incorrectly proceeds in cases where the fragment start is past the end of the original data, aka OVE-20180430-0004.

    • Обновитесь до 3.7.3-1ubuntu1.1
  3. CVE-2018-1000132

    Критический · CVSS 9.3EPSS 2,62%Есть исправление

    CVE-2018-1000132

    Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

    • Обновитесь до 3.7.3-1ubuntu1.1
    Опубликовано Обновлено
  4. CVE-2017-17458

    Критический · CVSS 9.8EPSS 6,33%Есть исправление

    CVE-2017-17458

    In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.

    • Обновитесь до 3.7.3-1ubuntu1.1
    Опубликовано Обновлено
  5. CVE-2017-1000116

    Критический · CVSS 9.8EPSS 6,37%Есть исправление

    CVE-2017-1000116

    Mercurial prior to 4.3 did not adequately sanitize hostnames passed to ssh, leading to possible shell-injection attacks.

    • Обновитесь до 3.7.3-1ubuntu1.1
    Опубликовано Обновлено
  6. CVE-2017-1000115

    Высокий · CVSS 8.7EPSS 4,81%Есть исправление

    CVE-2017-1000115

    Mercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository

    • Обновитесь до 3.7.3-1ubuntu1.1
    Опубликовано Обновлено
  7. CVE-2017-9462

    Высокий · CVSS 8.8EPSS 21,68%Публичный эксплойтЕсть исправление

    CVE-2017-9462

    In Mercurial before 4.1.3, "hg serve --stdio" allows remote authenticated users to launch the Python debugger, and consequently execute arbitrary code, by using --debugger as a repository name.

    • Обновитесь до 3.7.3-1ubuntu1.1
  8. CVE-2016-3105

    Высокий · CVSS 8.8EPSS 2,75%Есть исправление

    CVE-2016-3105

    The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

    • Обновитесь до 3.7.3-1ubuntu1.1

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →