p PatchFirst

CVE-2020-15704

CVE-2020-15704 · pppd arbitrary file read information disclosure vulnerability

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

CVSS 5.5 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • ppp

    Версии
    • ≥ 2.4.5, < 2.4.5-5ubuntu1.4: Затронуто; ≥ 2.4.5-5.1ubuntu2.3+esm2: Не затронуто (custom)
    • ≥ 2.4.7, < 2.4.7-1+2ubuntu1.16.04.3: Затронуто; ≥ 2.4.7-2+2ubuntu1.3: Не затронуто; ≥ 2.4.7-2+4.1ubuntu5.1: Не затронуто; ≥ 2.4.7-2+4.1ubuntu6: Не затронуто (custom)

    Обновитесь до 2.4.5-5.1ubuntu2.3+esm2; Обновитесь до 2.4.7-2+2ubuntu1.3

  • ppp Ubuntu:Pro:14.04:LTS

    Версии
    • 2.4.5-5.1ubuntu2
    • 2.4.5-5.1ubuntu2.1
    • 2.4.5-5.1ubuntu2.2
    • 2.4.5-5.1ubuntu2.3
    • 2.4.5-5.1ubuntu2.3+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.5-5.1ubuntu2.3+esm2

    Обновитесь до 2.4.5-5.1ubuntu2.3+esm2

  • ppp Ubuntu:16.04:LTS

    Версии
    • 2.4.6-3.1ubuntu1
    • 2.4.7-1+1ubuntu1
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+2ubuntu1.16.04.1
    • 2.4.7-1+2ubuntu1.16.04.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.7-1+2ubuntu1.16.04.3

    Обновитесь до 2.4.7-1+2ubuntu1.16.04.3

  • ppp Ubuntu:18.04:LTS

    Версии
    • 2.4.7-1+2ubuntu1
    • 2.4.7-1+4ubuntu1
    • 2.4.7-1+4ubuntu3
    • 2.4.7-2+1ubuntu1
    • 2.4.7-2+2ubuntu1
    • 2.4.7-2+2ubuntu1.1
    • 2.4.7-2+2ubuntu1.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.7-2+2ubuntu1.3

    Обновитесь до 2.4.7-2+2ubuntu1.3

  • ppp Ubuntu:20.04:LTS

    Версии
    • 2.4.7-2+4.1ubuntu4
    • 2.4.7-2+4.1ubuntu5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.7-2+4.1ubuntu5.1

    Обновитесь до 2.4.7-2+4.1ubuntu5.1

Первоисточники

Проверьте свой сервер →