UBUNTU-CVE-2026-85495
[pre-authentication global buffer overflow]
PatchFirst · Свежие уязвимости
За последние 30 дней в ppp опубликовано уязвимостей: 0; в каталоге KEV: 0.
Уязвимостей: 5
[pre-authentication global buffer overflow]
The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges.
The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.
eap.c in pppd in ppp 2.4.2 through 2.4.8 has an rhostname buffer overflow in the eap_request and eap_response functions.
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the `refuse-app` option are unaffected.
Сопоставьте установленный стек и версии со свежими базами уязвимостей.