p PatchFirst

CVE-2021-21336

CVE-2021-21336 · Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.

CVSS 6.5 · Средний · EPSS 1,5% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • products.pluggableauthservice

    Версии
    • < 2.6.0: Затронуто

    Нет опубликованного исправления

  • products-pluggableauthservice PyPI

    Версии
    • 1.10.0
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 1.5.2
    • 1.5.2.1
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.7.0
    • 1.7.0b1
    • 1.7.0b2
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 1.8.0
    • 1.9.0
    • 2.0
    • 2.0b1
    • 2.0b2
    • 2.0b3
    • 2.0b4
    • 2.0b5
    • 2.0b6
    • 2.1
    • 2.1.1
    • 2.2
    • 2.2.1
    • 2.3
    • 2.4
    • 2.5
    • 2.5.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.6.0

    Обновитесь до 2.6.0

  • products-pluggableauthservice PyPI

    Версии
    • 1.5.2
    • 1.5.2.1
    • 1.5.3
    • 1.5.4
    • 1.5.5
    • 1.6
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.7.0b1
    • 1.7.0b2
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.7.4
    • 1.7.5
    • 1.7.6
    • 1.7.7
    • 1.7.8
    • 1.8.0
    • 1.9.0
    • 1.10.0
    • 1.11.0
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 2.0b1
    • 2.0b2
    • 2.0b3
    • 2.0b4
    • 2.0b5
    • 2.0b6
    • 2.0
    • 2.1
    • 2.1.1
    • 2.2
    • 2.2.1
    • 2.3
    • 2.4
    • 2.5
    • 2.5.1
    Затронутые диапазоны версий
    • GIT: < 2dad81128250cb2e5d950cddc9d3c0314a80b4bb
    • ECOSYSTEM: < 2.6.0

    Обновитесь до 2.6.0

Первоисточники

Проверьте свой сервер →