p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости products-pluggableauthservice

За последние 30 дней в products-pluggableauthservice опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 3

  1. CVE-2021-33507

    Средний · CVSS 6.1EPSS 0,75%Есть исправление

    CVE-2021-33507

    Zope Products.CMFCore before 2.5.1 and Products.PluggableAuthService before 2.6.2, as used in Plone through 5.2.4 and other products, allow Reflected XSS.

    • Обновитесь до 2.6.2
  2. CVE-2021-21337

    Средний · CVSS 5.7EPSS 8,44%Публичный эксплойтЕсть исправление

    URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService

    Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an open redirect vulnerability. A maliciously crafted link to the login form and login functionality could redirect the browser to a different website. The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to `2.6.1` and re-run the buildout, or if you used `pip` simply do `pip install "Products.PluggableAuthService>=2.6.1".

    • Обновитесь до 2.6.1
    Опубликовано Обновлено
  3. CVE-2021-21336

    Средний · CVSS 6.5EPSS 1,5%Есть исправление

    Exposure of Sensitive Information to an Unauthorized Actor in Products.PluggableAuthService ZODBRoleManager

    Products.PluggableAuthService is a pluggable Zope authentication and authorization framework. In Products.PluggableAuthService before version 2.6.0 there is an information disclosure vulnerability - everyone can list the names of roles defined in the ZODB Role Manager plugin if the site uses this plugin. The problem has been fixed in version 2.6.0. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.0 and re-run the buildout, or if you used pip simply do `pip install "Products.PluggableAuthService>=2.6.0"`.

    • Обновитесь до 2.6.0
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →