CVE-2021-21389
CVE-2021-21389 · BuddyPress privilege escalation via REST API
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.
CVSS 8.1 · Высокий · EPSS 14,8% · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
buddypress
- Версии
- >= 5.0.0, < 7.2.1: Затронуто
Нет опубликованного исправления
buddypress/buddypress Packagist
- Версии
- 5.0.0
- 5.1.0
- 5.1.0-beta1
- 5.1.1
- 5.1.2
- 5.2.0
- 5.2.1
- 5.2.2
- 6.0.0
- 6.0.0-RC1
- 6.0.0-RC2
- 6.0.0-beta1
- 6.0.0-beta2
- 6.1.0
- 6.2.0
- 6.2.0-beta1
- 6.3.0
- 6.4.0
- 6.4.2
- 6.4.3
- 7.0.0
- 7.0.0-RC1
- 7.0.0-RC2
- 7.0.0-beta1
- 7.0.0-beta2
- 7.1.0
- 7.2.0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 5.0.0, < 7.2.1
Обновитесь до 7.2.1