p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости buddypress/buddypress

За последние 30 дней в buddypress/buddypress опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 5

  1. CVE-2026-53675

    Средний · CVSS 5.3EPSS 0,23%Нет опубликованного исправления

    BuddyPress 14.4.0 Friends List IDOR via REST API

    BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the friends REST API that allows any authenticated attacker to enumerate another user's complete friend list. Attackers can query the friends endpoint with an arbitrary user_id because the get_items_permissions_check method only verifies that the requester is logged in and never checks ownership of the requested list, resulting in disclosure of users' private social connections.

  2. CVE-2026-53673

    Высокий · CVSS 8.6EPSS 0,37%Есть исправление

    BuddyPress 14.4.0 Private Message IDOR via REST API user_id Parameter

    BuddyPress 14.4.0 contains an insecure direct object reference vulnerability in the messages REST API that allows authenticated attackers to access arbitrary private message threads by supplying a user_id parameter in the request. Attackers can pass another user's identifier to the get_item_permissions_check method, which validates the supplied user_id instead of the logged-in user and is reused by the update and delete handlers, to read, reply to, or delete any user's private messages.

    • Обновитесь до 14.5.0
  3. CVE-2021-21389

    Высокий · CVSS 8.1EPSS 14,81%Публичный эксплойтЕсть исправление

    BuddyPress privilege escalation via REST API

    BuddyPress is an open source WordPress plugin to build a community site. In releases of BuddyPress from 5.0.0 before 7.2.1 it's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the REST API members endpoint. The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue.

    • Обновитесь до 7.2.1
    Опубликовано Обновлено
  4. CVE-2020-5244

    Высокий · CVSS 8EPSS 2,44%Есть исправление

    Private data exposure via REST API in BuddyPress

    In BuddyPress before 5.1.2, requests to a certain REST API endpoint can result in private user data getting exposed. Authentication is not needed. This has been patched in version 5.1.2.

    • Обновитесь до 5.1.2
    Опубликовано Обновлено
  5. CVE-2017-6954

    Средний · CVSS 4.3EPSS 1,12%Есть исправление

    CVE-2017-6954

    An issue was discovered in includes/component.php in the BuddyPress Docs plugin before 1.9.3 for WordPress. It is possible for authenticated users to edit documents of other users without proper permissions.

    • Обновитесь до 1.9.3
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →