p PatchFirst

CVE-2021-21391

CVE-2021-21391 · Regular expression Denial of Service in multiple packages

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

CVSS 6.5 · Средний · EPSS 1,7% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • ckeditor5

    Версии
    • < 27.0.0: Затронуто

    Нет опубликованного исправления

  • @ckeditor/ckeditor5-engine npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-font npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-image npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-list npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-markdown-gfm npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-media-embed npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-paste-from-office npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • @ckeditor/ckeditor5-widget npm

    Затронутые диапазоны версий
    • SEMVER: < 27.0.0

    Обновитесь до 27.0.0

  • ckeditor3 Ubuntu:18.04:LTS

    Версии
    • 3.6.6.1+dfsg-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ckeditor3 Ubuntu:20.04:LTS

    Версии
    • 3.6.6.1+dfsg-3
    • 3.6.6.1+dfsg-4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ckeditor3 Ubuntu:22.04:LTS

    Версии
    • 3.6.6.1+dfsg-7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ckeditor3 Ubuntu:24.04:LTS

    Версии
    • 3.6.6.1+dfsg-7
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →