p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости @ckeditor/ckeditor5-engine

За последние 30 дней в @ckeditor/ckeditor5-engine опубликовано уязвимостей: 2; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 3

  1. CVE-2026-116688

    Высокий · CVSS 8.1EPSS 0,5%Есть исправление

    CKEditor: Cross-site scripting (XSS) in the engine package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 45.0.0 until 47.7.4 and 48.5.1, the engine uses a vulnerable es-toolkit version whose prototype-pollution behavior can be reached while CKEditor processes incoming style attribute values. Crafted editor content can thereby cause unauthorized JavaScript execution in the browser. This issue is fixed in versions 47.7.4 and 48.5.1.

    • Обновитесь до 47.7.4
    • Обновитесь до 48.5.1
    Опубликовано Обновлено
  2. CVE-2026-116687

    Низкий · CVSS 3.1EPSS 0,25%Есть исправление

    CKEditor: Cross-site scripting (XSS) in the engine package

    CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. From 29.0.0 until 47.7.4 and 48.5.1, specially crafted markup can trigger cross-site scripting when General HTML Support is enabled and specifically configured to allow object content. Processing that content can execute attacker-controlled JavaScript in a browser context isolated from the origin of the application embedding the editor. This issue is fixed in versions 47.7.4 and 48.5.1.

    • Обновитесь до 47.7.4
    • Обновитесь до 48.5.1
    Опубликовано Обновлено
  3. CVE-2021-21391

    Средний · CVSS 6.5EPSS 1,67%Есть исправление

    Regular expression Denial of Service in multiple packages

    CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem

    • Обновитесь до 27.0.0
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →