p PatchFirst

CVE-2021-32809

CVE-2021-32809 · Arbitrary HTML injection vulnerability in ckeditor

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

CVSS 4.6 · Средний · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • ckeditor4

    Версии
    • >= 4.5.2, < 4.16.2: Затронуто

    Нет опубликованного исправления

  • ckeditor Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.16.2+dfsg-1

    Обновитесь до 4.16.2+dfsg-1

  • ckeditor4 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.5.2, < 4.16.2

    Обновитесь до 4.16.2

  • ckeditor Ubuntu:Pro:16.04:LTS

    Версии
    • 4.4.4+dfsg1-3
    • 4.5.6+dfsg-1
    • 4.5.7+dfsg-1
    • 4.5.7+dfsg-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.16.04.1~esm1

    Обновитесь до 4.5.7+dfsg-2ubuntu0.16.04.1~esm1

  • ckeditor Ubuntu:18.04:LTS

    Версии
    • 4.5.7+dfsg-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.18.04.1

    Обновитесь до 4.5.7+dfsg-2ubuntu0.18.04.1

  • ckeditor Ubuntu:20.04:LTS

    Версии
    • 4.11.1+dfsg-1
    • 4.12.1+dfsg-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.12.1+dfsg-1ubuntu0.1

    Обновитесь до 4.12.1+dfsg-1ubuntu0.1

Первоисточники

Проверьте свой сервер →