p PatchFirst

PatchFirst · Свежие уязвимости

Уязвимости ckeditor

За последние 30 дней в ckeditor опубликовано уязвимостей: 0; в каталоге KEV: 0.

Фильтры уязвимостей
Сбросить фильтры

Уязвимостей: 4

  1. CVE-2021-37695

    Высокий · CVSS 7.3EPSS 1,32%Есть исправление

    Execution of JavaScript code using malformed HTML in ckeditor

    ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Fake Objects](https://ckeditor.com/cke4/addon/fakeobjects) package. The vulnerability allowed to inject malformed Fake Objects HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version < 4.16.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

    • Обновитесь до 4.12.1+dfsg-1ubuntu0.1
    Опубликовано Обновлено
  2. CVE-2021-32809

    Средний · CVSS 4.6EPSS 1,19%Есть исправление

    Arbitrary HTML injection vulnerability in ckeditor

    ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

    • Обновитесь до 4.12.1+dfsg-1ubuntu0.1
    Опубликовано Обновлено
  3. CVE-2021-33829

    Средний · CVSS 6.1EPSS 3,19%Публичный эксплойтЕсть исправление

    CVE-2021-33829

    A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!> is mishandled.

    • Обновитесь до 4.12.1+dfsg-1ubuntu0.1
  4. CVE-2020-9281

    Средний · CVSS 6.1EPSS 4,31%Есть исправление

    CVE-2020-9281

    A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14 allows remote attackers to inject arbitrary web script through a crafted "protected" comment (with the cke_protected syntax).

    • Обновитесь до 4.12.1+dfsg-1ubuntu0.1
    Опубликовано Обновлено

Проверьте свой сервер

Сопоставьте установленный стек и версии со свежими базами уязвимостей.

Проверьте свой сервер →